Plugins, Plugins and Integrations

Plugins » Incompatible Plugins

While the vast majority of plugins are supported here at WordPress.com, there are some that are not. This page contains a running list of these unsupported plugins and the reasons why.

Table of Contents

Introduction

Sites with a plugin-enabled plan have access to tens of thousands of plugins in the WordPress ecosystem. Plugins give your site superpowers, helping you turn your dreams into reality.

In the case of many of these plugins, we already provide identical or superior functionality on WordPress.com. Therefore, installing additional plugins wouldn’t improve your site’s performance or features, and could negatively affect it instead.

We are not implying that all plugins on this page are bad. By disallowing these plugins, we wish to ensure a scalable and efficient hosting environment for all our customers.

If you want to install a plugin on this page, feel free to get in touch, and we’ll help you find an alternative option.

↑ Table of Contents ↑

Caching Plugins

WordPress.com is already equipped with its own robust caching solution, which is able to scale at a global level without any additional intervention on your side. Thus, installing another caching plugin will not work and may have unintended consequences like crashing your site.

The following plugins can interfere with the existing caching system on your site:

  • Breeze — WordPress Cache Plugin
  • Comet Cache
  • Cache Enabler
  • Fast Velocity Minify
  • Hyper Cache
  • JCH Optimize
  • Powered Cache
  • Quick Cache
  • SiteGround Optimizer (known by the slug sg-cachepress)
  • W3 Total Cache
  • WP Cache
  • WP Fastest Cache
  • WP Speed Of Light
  • WP Super Cache

↑ Table of Contents ↑

Backup Plugins

If you are worried about losing data, rest assured that we make daily backups of your site. Go to Jetpack → Backups to restore or download a backup of your site from a specific point in time.

These plugins are not supported because they may negatively impact your site’s performance with excessive resource usage:

  • Backup Guard
  • Backup WD
  • BackUpWordPress
  • BackWPup
  • Clone
  • Database Backup for WordPress
  • Duplicator
  • SiteGround Migrator
  • WP BackItUp Community Edition
  • WP DB Backup

Please note: If you want to migrate a WordPress.com site to another site hosted at WordPress.com, see our Import options.

↑ Table of Contents ↑

SQL-Heavy Plugins

These plugins put a high strain on our servers due to the exorbitant number of SQL queries they create:

  • Adnow Plugin
  • Broken Link Checker
  • ImageInject
  • Leads
  • Page Visit Counter
  • Post Views Counter
  • Slimstat Analytics
  • TokenAd
  • Top 10
  • UserPro
  • WordPress Classifieds Plugin
  • WordPress Popular Posts
  • WP Cerber Security, Anti-spam & Malware Scan
  • WP-PostViews
  • WP RSS Aggregator
  • WP Session Manager
  • WP Statistics
  • WP ULike

↑ Table of Contents ↑

Database / File System Altering Plugins

These plugins allow users to delete essential files or SQL data that often result in a broken website. If you wish to reset your site, delete a file, or run a query, please don’t hesitate to contact us for assistance.

  • Advanced Database Cleaner
  • Advanced File Manager
  • Advanced Reset WP
  • Advanced WP Reset
  • ARI Adminer
  • CiviCRM
  • Database Backup for WordPress
  • Database Browser
  • Database Reset
  • Extended WP Reset
  • File Manager
  • Hide My WP
  • Plugins Garbage Collector (Database Cleanup)
  • Reset WP
  • Secure File Manager
  • Ultimate Reset
  • Ultimate WordPress Reset
  • WordPress File Upload
  • WordPress Reset
  • WP CleanFix
  • WP Config File Editor
  • WP-DBManager
  • WP Downgrade
  • WP File Manager
  • WP Prefix Changer
  • WP Reset
  • WP Uninstaller by Azed
  • WPMU Database Reset
  • Z Inventory Manager

↑ Table of Contents ↑

Email Plugins

Emails are an essential part of any website. However, there are some plugins that send spam emails that we cannot allow:

  • E-mail Broadcasting
  • Mailit
  • Send Email from Admin

As an alternative, you may want to check out a third-party email solution such as Mailchimp or MailPoet. You can integrate MailChimp forms easily into your site.

↑ Table of Contents ↑

Automated Content Plugins

We know it can be tempting to automatically import content from around the web using content scrapers. We’ve found that these sorts of plugins are not a good fit for sites hosted at WordPress.com. Not only do they place unnecessary loads on the infrastructure, but automated posting is also often seen as spam and is generally unwanted.

  • Blogmatic
  • Octolooks Scrapes
  • RSS Feed to Post
  • Woozone/WZone
  • WordAi Aggregator
  • WP Automatic
  • WP Inject
  • WP RSS Aggregator
  • WPeMatico RSS Feed Fetcher
  • WPRobot5

↑ Table of Contents ↑

Miscellaneous

Other incompatible plugins that don’t fall into a particular category are listed below:

  • 10Web Player for Youtube (YouTube player and gallery)
  • Adult Mass Photos Downloader
  • Adult Mass Videos Downloader
  • Automatic Video Posts
  • Better WordPress Minify
  • BWP Minify
  • CDN Enabler
  • CF7 Pipedrive Integration
  • Clearfy
  • Cornerstone
  • Cryptocurrency Pricing list and Ticker
  • Disable XML-RPC
  • Easy Username Updater
  • Event Espresso
  • FacetWP Manipulator
  • Flo Launch
  • Image Gallery by Robo
  • iThemes Security (formerly Better WP Security)
  • Leads
  • Monero Miner Pro
  • Nginx Helper
  • Noo Indeed Integration PluginPorn Embed
  • Patron Button and Widgets by Codebard
  • PHP Settings
  • Pigdig P3
  • Post Type Switcher
  • PropellerAds Official Plugin
  • Really Simple SSL
  • Shield Security
  • Speed Contact Bar
  • Trafficzion
  • Unplug Jetpack
  • Username Changer
  • Video Importer
  • WordFence Security
  • WP Hardening
  • WP-Inject (now known as ImageInject)
  • WP Monero Miner
  • WP Optimize By xTraffic
  • WP Optimizer
  • WP Staging
  • WPS Hide Login
  • Yuzo Related Post
  • Zapp Proxy Server Plugin

↑ Table of Contents ↑

ABSPATH

Some themes and plugins break due to incorrect usage of the ABSPATH variable in requiring files or writing into folders.

You may not use ABSPATH on our platform, as this points to the core WordPress folder, unless you are requiring a core file. Instead, you must use WP_CONTENT_DIR, which is defined on our system as /htdocs/wp-content. When requiring a file, it would look like:

require_once( WP_CONTENT_DIR . '/plugins/plugin-stuff/stuffs.php' );

Otherwise, if on other hosting platforms WP_CONTENT_DIR wasn’t defined, it would default to:

ABSPATH . 'wp-content'

↑ Table of Contents ↑

FAQ

My plugin says I need ionCube Loader. What’s that, and do I have it?

The ionCube Loader is a PHP module used to hide and obfuscate PHP code.  Some plugins such as AliDropShip require this to be installed on your site’s server to function. At the present time, we do not run ionCube on our servers. As a result, any plugins that rely on it will not function on WordPress.com-hosted sites.

💡

Looking for an alternative to the AliDropShip plugin? The WooCommerce Dropshipping extension supports importing products from AliExpress and is compatible with WordPress.com.

My plugin says the database doesn’t support a character set. What do I do?

Some plugins, notably Convertkit, require a particular database character set, such as UTF-8. Sites on WordPress.com use Latin1 as a character set. If a plugin requires a different character set, please contact the developers for an alternative solution.

This page is subject to change without prior notice. 

Not quite what you're looking for?

Get Help