Notes de bas de page

  • Auteur
    Articles
  • #14303

    Bonjour,
    Après avoir recherché dans le forum, il me semble que le sujet des notes de bas de page n’y est pas du tout traité. Mes questions sont donc les suivantes : est-il possible d’intégrer des notes de bas de page dans un article wordpress.com ? Si oui, comment procéder ?
    J’imagine que cela est possible, mais je crains que ce soit une option payante. Je me trompe ?
    Merci d’avance pour vos réponses !

    L’adresse du blog concerné est lesarchivesdescamarades.wordpress.com.

    #14664

    airodyssey
    Modérateur

    Bonjour. Vous pourriez faire ceci (et c’est gratuit) :
    1) à la fin de votre article, écrire les notes de bas de page à votre guise
    2) cliquer sur l’onglet HTML et insérer le code suivant juste avant la ou les notes voulues :
    <a name="notes"></a>
    3) dans le texte, à l’endroit voulu, insérer un lien vers l’adresse suivante :
    #notes
    Bien sûr, vous pouvez remplacer le nom « notes » par ce que vous voulez, particulièrement si vous voulez différents liens pointant vers différentes notes de bas de page.
    Est-ce que cela répond à votre question?

    #14666

    emmaltepe
    Membre

    Bonjour,

    C’est possible, et gratuit… :)
    Par contre, elles sont à coder « en dur », à partir de l’éditeur html, en utilisant les attributs « name » et « # » qui se répondent ; ce n’est pas compliqué en soi, il faut juste faire attention à ne pas s’emmêler les pinceaux :
    – la note de bas de page : insérer une balise « a name= »note1(par exemple) » qui encadre le numéro ou l’ensemble de la note ;
    – le texte ou la numérotation qui y conduit : balise « a href= « #note1(par exemple) »qui encadre le numéro ou un groupe de mots.
    – Si vous voulez ajouter un retour au texte depuis la note, même procédure, dans l’autre sens.

    Ce qui donne, en admettant que vous souhaitiez insérer le texte et la note ci-dessous, avec retour au texte :

    Lorem ipsum dolor sit amet, consectetur adipiscing elit (1). Aenean odio ipsum, adipiscing vehicula cursus ac, rutrum in felis.
    —–
    Note :
    (1) Nam quis ipsum nibh, ac lacinia augue (retour au texte)

    Le code suivant :

    <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit (<a name="retour au texte" href= "#note1"> 1</a>). Aenean odio ipsum, adipiscing vehicula cursus ac, rutrum in felis. </p>
    -----
    <p>Note :
    <a name= "note1">(1)</a> Nam quis ipsum nibh, ac lacinia augue (<a href= "#retour au texte">retour au texte1</a>)</p>

    Et encore mieux, vous pouvez ajouter le contenu de votre note dans la balise avec l’attribut « title » ; de cette manière, vos lecteurs pourront la lire en survolant le lien avec la souris.
    Avec l’exemple ci-dessus, le code de la partie texte sera donc :
    <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit (<a title="Nam quis ipsum nibh, ac lacinia augue" name="retour au texte" href= "#note1"> 1</a>). Aenean odio ipsum, adipiscing vehicula cursus ac, rutrum in felis. </p>

    (Si je ne me suis pas emmêlé les pinceaux dans mes explications :D)

    maltepe

    #14667

    emmaltepe
    Membre

    Airodyssey a été plus vif… ;)

    maltepe

    #14668

    airodyssey
    Modérateur

    @emmaltepe : Votre explication a le mérite d’être très complète. Merci ;-)

    @lesarchives… : Merci de nous confirmer si nos explications vous sont utiles :-)

    #14669

    emmaltepe
    Membre

    @airodyssey : merci… :)

    maltepe

    #14670

    Merci beaucoup pour ces explications et suggestions ! Elles répondent bien à ma question ! Je vais essayer de les appliquer et vous donnerez des nouvelles. Et je ne manquerai pas de signaler que le problème est résolu. A bientôt !

    #14708

    transliterra
    Membre

    J’ai essayé les deux formules, malheureusement, le code disparaît dans la deuxième formule : ( 1).
    Dans la première formule, à chaque fois que j’édite en HTML, je retrouve le code déplacé : (1) au lieu de celui qui est corect : (1)
    Le retour au texte ne fonctionne pas non plus.
    J’ai réédité plusieurs fois, sauvegardé, mais ça bug.

    #14709

    transliterra
    Membre

    Ayant vu que cela fonctionne sur ce forum, je viens de réessayer.
    Rien à faire, le code est modifié : ( 1)

    #14710

    transliterra
    Membre

    le code incorrect : ( 1)
    J’ai remplacé par des apostrophes pour qu’il aparaisse

    #14711

    transliterra
    Membre

    rien à faire, il n’apparaît pas.

    #14712

    emmaltepe
    Membre

    Bonjour transliterra,

    Pour que le code apparaisse, vous devez le placer entre deux accents graves, et non des apostrophes… :-)

    maltepe

    #14713

    transliterra
    Membre

    oui, tout à fait.

    si j’ai mis des apostrophes, c’est pour qu’il apparaisse sur le forum avec l’erreur induite.

    #14714

    transliterra
    Membre

    voici l’article en question :
    http://transliterra.wordpress.com/2011/08/18/villequier-et-victor-hugo/

    j’ai placé la note (1)

    #14715

    emmaltepe
    Membre

    Votre code fonctionne :-) : en cliquant sur (1), on arrive bien à la note de bas de page.
    Pour le retour au texte, vous devez faire la même chose, dans l’autre sens : choisissez où vous voulez précisément que le lecteur revienne, mettez-y la balise « a name= » ; dans la note de bas de page, ajoutez par exemple une parenthèse (retour au texte) où vous insérerez la balise « a href=# », exactement comme vous l’avez fait pour la note (mais avec d’autres noms)
    Par exemple, à la citation :
    <a name="citation" href="#1">(1)</a>

    et en fin de note :
    (<a href="#citation">retour au texte</a>)

    maltepe

    #14716

    transliterra
    Membre

    oui, le code fonctionne.
    je parle là d’un problème technique dans l’éditeur de texte :
    1 :j’inscris le code en mode HTML dans mon texte, puis je reviens en mode visuel pour vérifier l’apparence de l’article.
    2 :Quand je repasse en mode HTML, je m’aperçois que le code est modifié et il ne fonctionne plus correctement dans mon article.
    J’essayais donc d’expliquer ce bug en inscrivant les codes et les modifications que je constate à la ré-édition en mode HTML.
    Maintenant, je constate que le résultat est ok <b>si je reste en mode HTML</b> sans repasser en mode visuel dans l’éditeur de texte. Sinon, cela bug.

    #14717

    transliterra
    Membre

    J’ai suivi à la lettre les codes que vous avez indiqués et qui ne sont pas difficiles à comprendre, il n’y a que deux éléments. Maintenant, le retour à l’article se fait correctement, mais on n’arrive plus à la note de bas de page.
    Bon, je laisse tout cela. (le temps passe…)

    Merci pour tout.

    #14718

    emmaltepe
    Membre

    Maintenant, le retour à l’article se fait correctement, mais on n’arrive plus à la note de bas de page.

    C’est la situation que je constate actuellement… :-S….

    Alors…
    Le passage de l’éditeur html à l’éditeur visuel est connu pour générer quelques soucis, des balises qui « sautent », notamment. Mais la balise « a » généralement tient, et je ne me souviens pas avoir eu de problème pour des notes de bas de page.
    Un conseil : rédigez votre article, notes comprise, dans l’éditeur qui vous convient. Sauvegardez. Passez en éditeur html pour insérer vos liens. Sauvegardez, et ne repassez plus en mode visuel. Si c’est une histoire de balise qui saute, votre article, liens compris, devrait être préservé.

    —–

    En regardant le code source de votre page, il y a erreur de code dans vos notes de bas de page, ce qui explique qu’on n’y accède pas (est-ce une erreur humaine ou liée au passage hml/visuel ?, je ne sais pas)

    Vous avez pour codes de la note 1 :
    – dans le texte :
    <a name="citation1" href="#1">(1)</a>
    – en note :
    <a name="citation1"><em><strong>1</strong></em></a>
    Et de la note 2
    – dans le texte :
    <a name="citation2" href="#2">(2)</a>
    – en note :
    <a name="citation2"><em><strong>2</strong></em>

    Alors que selon les codes dans le texte ( qui sont complets), vous devriez avoir :
    – pour la note 1 :
    <a name="1"><em><strong>1</strong></em></a>
    (ce que vous aviez lors de votre précédent message)
    – pour la note 2 :
    <a name="2"><em><strong>1</strong></em></a>

    Je pense que vous vus êtes emmêlé les pinceaux entre « name » et « # » , ce que je présentais comme le principal risque de l’opération… ;-)
    (je me trompe presque à chaque fois, et pourtant, je n’en suis pas à ma première note de bas de page, si ça peut vous consoler ou rassurer).

    Encore : à l’avenir, lors d’une question sur le forum, essayez d’insérer dans votre message le code incriminé, en le copiant-collant entre deux accents graves : il sera directement accessible, et les réponses sans doute plus rapides que s’il est nécessaire d’aller chercher le code-source de la page. :-)

    En espérant que votre souci soit réglé,

    Belle soirée,

    maltepe

    #14720

    emmaltepe
    Membre

    À retenir, donc :
    <a name="blablabla">texte</a>
    est à appliquer à la destination.

    <a href="#blablabla">texte</a>
    est à appliquer à ce qui pointe vers la destination.

    « blablabla » doit être identique pour que le lien fonctionne.


    maltepe

    #14723

    transliterra
    Membre

    J’ai corrigé les parenthèses.
    comme j’ai codé plusieurs fois, je ne me suis pas aperçue que j’avais laissé les parenthèses à l’intérieur du code, alors qu’auparavant, elles étaient à l’extérieur. Ce qui donne 1 pour 1 et non plus (1) pour 1.

    Concernant le code, j’ai bien essayé de le mettre dans mes premiers messages, mais entre apostrophes.

    De toutes façons, ça ne fonctionne tjs pas.

    Bonne soirée à vous également

    Je rédige le plus souvent en mode HTML et tous mes liens sont en HTML, en mode visuel, ils disparaissent.
    La balise tient, c’est le texte lui-même qui est éjecté de la balise et se trouve en dehors, juste à côté du code, lorsqu’on passe de l’éditeur HTML à l’éditeur visuel. Ce qui fait que le code est vidé de son contenu.

Le sujet ‘Notes de bas de page’ est fermé aux nouvelles réponses.