Yearly archive pages on Masthead truncated at 10 posts

  • Author
    Posts
  • #268755

    2020science
    Member
    Original poster

    I’m using DePo Masthead for a blog that is about to be launched, and have just noticed that the “Archive” link at the top of the page only pulls up the ten latest posts for each year displayed.

    How do I get this link to show all the posts for the year selected?

    Cheers,

    Andrew

    #268929

    raincoaster
    Member

    You probably have your blog set to show 10 posts per page; this is universal and will affect your archives. The only way I know to override it is not to use the Archive widget at all; use a Text widget, and make a static page where you list all your archives. You have to update that manually, both page and widget.

    #268932

    The “archive” page accessible from the top navigation is in essence, just like the main blog page with other themes. DePo is a magazine theme and operates entirely differently from other themes.

    /nod to raincoaster, yes do as she suggests and go to settings reading and change the number of posts to show on a page and it will change the number shown on the “archive” page.

    It perhaps was a poor choice of titles for that page by the designer.

    #268933

    raincoaster
    Member

    Ah, thanks for the clarification.

    #268934

    I’ve messed around with on one of my test blogs for a while. You almost have to throw out everything you have known about themes when you switch to DePo. Reminds me of the line from Monty Python’s Flying Circus, “And now for something completely different.”

    #268935

    2020science
    Member
    Original poster

    Great tip raincoaster – I should have spotted this!

    Setting the number of posts to show to a large number resolves the issue.

    Thanks!

The topic ‘Yearly archive pages on Masthead truncated at 10 posts’ is closed to new replies.