XML Sitemaps for Search Engines

  • Author
    Posts
  • #359107

    karlrzweifel
    Member
    Original poster

    after entering “http://karlrzweifel.wordpress.com/sitemap.xml” I get following reply: «Page not found»
    what am I doing wrong?

    The blog I need help with is: karlrzweifel.wordpress.com

    #359269

    I see your sitemap just fine.

    It does appear though that if you have a blog set to private, or have disallowed search engines that the sitemap is not generated here at wordpress.com. It is only generated when you have the top selection active under settings > privacy.

    #359382

    karlrzweifel
    Member
    Original poster

    Thank you for your information. In the settings I have ticked, that I want the searchengines to find my entries:
    (I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers)

    Now after entering my blogname: karlrzweifel.wordpress.com/sitemap.xml
    The reply now is no more «PAGE NOT FOUND»
    I receive the following reply:

    http://karlrzweifel.wordpress.com/karl/ weekly 0.6 2009-05-01T07:02:55+00:00 http://karlrzweifel.wordpress.com/who-are-we-%e2%80%94-wer-sind-wir/ weekly 0.6 2009-05-03T03:18:34+00:00 http://karlrzweifel.wordpress.com/our-photos-%e2%80%94-unsere-fotos/ weekly 0.6 2009-05-02T08:53:35+00:00 http://karlrzweifel.wordpress.com/2009/05/01/happy-birthday-jr/ weekly 0.6 2009-05-01T08:57:40+00:00 http://karlrzweifel.wordpress.com/2009/05/01/schweiz/ weekly 0.6 2009-05-02T03:09:44+00:00 http://karlrzweifel.wordpress.com/2009/05/01/in-english/ weekly 0.6 2009-05-04T01:36:03+00:00 http://karlrzweifel.wordpress.com/ daily 1.0 2009-05-04T01:36:03+00:00

    I tried to enter some of the replies into Google but it is coming back as faulty.

    WHAT MUST I DO?

    #359394

    You don’t copy and paste that stuff from your site map to google. What exactly are you trying to do?

    #359402

    karlrzweifel
    Member
    Original poster

    Dear Friend
    I deleted everything which was rejected from Google-Webmaster-Tools as faulty.
    Yesterday, after entering: karlrzweifel.wordpress.com/sitemap.xml the reply again was «Page not found»
    Just no I entered again karlrzweifel.wordpress.com/sitemap.xml the reply again was above mentioned lines.
    Under XML Sitemaps for Search Engines in WordPress-Support is printed:
    Your blog is enabled with just about everything you need to be super-searchable. This includes an XML sitemap, which you can access at yourblogname.wordpress.com/sitemap.xml.
    I haven’t done anything anymore sincew everything supposed to be done by WordPress!

    There is a Blog with my name >>> address http://KARLRZWEIFEL.BLOG.COM which is not me!

    Could that be the reason why my blog with wordpress does not appear with Google search?

    I am at the end now!
    Kind regards and thank you for your assistance.
    Karl

    #359405

    I don’t think that the wordpress.COM sitemap can be used for verifying a blog with Google.

    You need to look at this support document and follow the instructions there to verify your site with Google: http://support.wordpress.com/verifying-with-google-webmaster-tools/ .

    #359406

    karlrzweifel
    Member
    Original poster

    Dear Friend

    I now completely followed your instruction and the instruction «Verifying with Google Webmaster Tools»
    Nowhere I can find any link to verify my site. I deleted my site and added again – still no link to verify!

    I cannot do any of the following points:

    You will be presented with several verification methods. Choose Upload an HTML file.
    Copy the filename, which looks something like google1234567890abcdefgh.html
    Leave the verification page open and go to your blog dashboard.
    Create a new page (not a post) with the filename as a title and publish it. Don’t worry if the dot from the filename is stripped, like in google1234567890abcdefgh html.
    Go back to the verification page and click Verify.

    #359407

    Did you create a page on your blog and for the title of that page put the google code from the verify page at google and then publish that page? Since you don’t have the pages widget in your sidebar I can’t tell if you have created that page or not.

    #359408

    OK, I was at the wrong site. This is the site you are talking about http://karlrzweifel.wordpress.com . You need to do as I said and create a page, put the google code into the title for that page and then publish that page.

    Once the verification is done, then you can make that google verification page you created a “child” of another page, such as the about page so that it doesn’t show in the top navigation.

    #359409

    karlrzweifel
    Member
    Original poster

    I cannot click anything to «Choose Upload an HTML file»
    Nowhere I get a file which «looks something like google1234567890abcdefgh.html»

    #359410

    karlrzweifel
    Member
    Original poster

    I deleted my site again, added again and I recive the following:

    Die Website wurde Ihrem Konto hinzugefügt. Bestätigen Sie, dass Sie der Eigentümer sind, um detaillierte Statistiken und Fehler anzeigen zu können.

    Which is telling me (in German) to confirm that I am the owner of the site – but nowhere any button or link to click!

    #359411

    raincoaster
    Member

    Don’t delete the site! You can’t use that URL again once the blog is deleted. Never.

    Or are you talking just about the post? That’s fine to delete if you want.

    #359414

    karlrzweifel
    Member
    Original poster

    Dear friend, I deleted and added again – it still is there, but i dont have an xml sitemap to my blog!

    #359422

    karlrzweifel
    Member
    Original poster

    Dear Friends and specialists
    I still don’t have any XML Sitemap!
    Still nowhere a link to VERIFY my website!
    After entering: http://karlrzweifel.wordpress.com/sitemap.xml
    I get following reply:
    http://karlrzweifel.wordpress.com/our-address-unsere-adresse/karl/ weekly 0.6 2009-05-05T07:30:10+00:00 http://karlrzweifel.wordpress.com/our-address-unsere-adresse/who-are-we-%e2%80%94-wer-sind-wir/ weekly 0.6 2009-05-05T07:29:28+00:00 http://karlrzweifel.wordpress.com/our-photos-%e2%80%94-unsere-fotos/ weekly 0.6 2009-05-05T07:31:17+00:00 http://karlrzweifel.wordpress.com/our-address-unsere-adresse/ weekly 0.6 2009-05-05T07:27:28+00:00 http://karlrzweifel.wordpress.com/2009/05/01/happy-birthday-jr/ weekly 0.6 2009-05-01T08:57:40+00:00 http://karlrzweifel.wordpress.com/2009/05/01/schweiz/ weekly 0.6 2009-05-05T14:53:16+00:00 http://karlrzweifel.wordpress.com/2009/05/01/in-english/ weekly 0.6 2009-05-04T01:36:03+00:00 http://karlrzweifel.wordpress.com/2009/05/04/berichtigung-rectification/ weekly 0.6 2009-05-05T07:40:00+00:00 http://karlrzweifel.wordpress.com/ daily 1.0 2009-05-05T14:53:16+00:00

    What am I doing wrong along all the lines – maybe WORDPRESS.COM is not for me! ! !

    Even concerning Turbo Gears nothing has changed!

    #359438

    karlrzweifel
    Member
    Original poster

    It really looks that nobody of all these members worldwide can help me to set up an XML Sitemap!
    It is not working even on the support page it explains that all will done automatically? >>>>> Your blog is enabled with just about everything you need to be super-searchable. This includes an XML sitemap,
    But who can tell me, where my XML Sitemap is? Is everybody sure that wordpress is working in the Philippines?
    Is there anywhere an engineer who maybe could help me?
    Thank you very much for your time reading my problems.
    Karl

    #359439

    tellyworth
    Staff

    Karl,

    All WordPress.com blogs have XML sitemaps built-in. They just work. You don’t need to verify with Webmaster Tools for Google to use your sitemap.

    http://karlrzweifel.wordpress.com/sitemap.xml is XML, it’s not meant for viewing in a web browser – what you’re seeing when you look at that page is normal.

    If you’d like to verify your site with Webmaster Tools anyway, this explains how:

    http://support.wordpress.com/verifying-with-google-webmaster-tools/

    #359454

    karlrzweifel
    Member
    Original poster

    Today, May 14, Google Webmaster Tools still lists that I have to add the XML Sitemap? ? ? ? Even WordPress Support explains that this will be done automatically. Where is my XML Sitem,ap now after ^two weeks membership? Somwhere along the line is something not correct working!

    #359455

    @karl, The site map will not show up as a page on your blog. It is a hidden file wordpress creates and updates as you add to and change your blog. Google can find it as can the other search engines and they use it, but it WILL NOT be visible on your blog.

    To verify your blog with Google, you have to create a page on your blog and title it with the code that Google gives you when you start the verification process which looks something like this: google1234567890abcdefgh.html (your code will be unique and different from the sample I’ve given). That has to be the title of the page you create. You then have to publish the page so that it appears on your blog. Then you switch back to Google verification page and click Verify. Google will then look at your blog, verify it and then all will be good.

    Again, this is from the instructions here on verifying your blog with Google Webmaster Tools:

    Here is how to register your WordPress.com blog in Google Webmaster Tools:

    1. Log in to https://www.google.com/webmasters/tools/ with your Google account.
    2. Enter your blog URL and click Add Site.
    3. In order to access most of the features, you will have to verify your site, so click on the Verify link.
    4. You will be presented with several verification methods. Choose Upload an HTML file.
    5. Copy the filename, which looks something like google1234567890abcdefgh.html
    6. Leave the verification page open and go to your blog dashboard.
    7. Create a new page (not a post) with the filename as a title and publish it. Don’t worry if the dot from the filename is stripped, like in google1234567890abcdefgh html.
    8. Go back to the verification page and click Verify.

    If you don’t want to see this artificial page along with your meaningful ones, see how to hide it.

The topic ‘XML Sitemaps for Search Engines’ is closed to new replies.