WordPress RSS feed not working.

  • Author
  • #1470507

    Hi there. This is my first attempt at setting up a podcast and have uploaded seven different mp3 messages for our church website so far. I’m using WordPress.com, Archive.org and FeedBurner and for the most part, it is all working. The intention is to included an RSS feed to iTunes to make the subscription process much easier for people who wish to keep up to date with, or to download, the latest messages but so far, I can’t work out what to do at what I hope is my last hurdle. FeedBurners Feedmedic says that all is well, however Podmedic comes up with – “The content type returned from your host server was a text type, not a binary media type. Podcast content should always return a binary media type, such as audio/mpeg for audio, or video/mpeg for video.” I’ve researched as much as I can, but can’t work out what I need to do to fix this. Can anyone steer me through a solution please as when I test the Podcast at iTunes, it accepts the Podcast ok, but does not have any of the attached messages. I suspect it is to do with “enclosures”, but do not know how to fix this.
    Thanks for any help.

    The blog I need help with is pukekohecommunitychurch.wordpress.com.



    I’m sorry but I have no experience with podcasting. All I can do is provide the link http://en.support.wordpress.com/audio/podcasting/ and then tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.




    Have you reviewed the link from timethief at http://en.support.wordpress.com/audio/podcasting/ , specifically the Feedburner instructions for denoting that it is a podcast?

    If you could send over a link to a post being used for the podcast as well as the feed URL you’re using, that would be very helpful too.



    Hi and thanks for your help and interest in solving my problems for me :) Sorry about the delay in responding but have spent most of the last two days in airplanes. I’ve gone over the link kindly provided by timethief but still not solved the issue. It appears to be in the way that I have the feed setup with Feedburner. It says that my feed is a web page and not a feed? Here is the link to one of the posts – http://pukekohecommunitychurch.wordpress.com/2013/10/07/its-all-about-the-heart/, and here is the feed URL that I am using – http://pukekohecommunitychurch.wordpress.com/wp-admin/edit.php?category_name=christian-teaching. Hope this helps.



    That is the wrong URL. That is an administrator’s editing view of a category, and nobody but the blog admin can access that page.

    I believe the feed URL you want is http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed if you want all your podcast posts in the feed.


    Thanks raincoaster as that has removed the podmedic errors. When I try to subscribe to the podcast within iTunes to test the podcast however, it still does not have any of the seven current mp3 messages. Is there something else that I still haven’t got right yet?



    I’m afraid that’s the limit of my knowledge. Try the other threads on https://en.forums.wordpress.com/tags/itunes and https://en.forums.wordpress.com/tags/podcasts


    Thanks for trying. I’m sure we’re getting there slowly. Probably just one more small correction and it’ll be iTunes compatible. Only other issue to resolve is where and how to store the PNG graphic for use as the iTunes cover picture.




    Hope y’all had a great weekend. What is the address you’re using to subscribe in iTunes? I’d like to test on my end so we have the same end goal to consider everything working.

    It should be, per our instructions and if I’m understanding your setup correctly, the FeedBurner URL. (The http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed is used within FeedBurner, then the Feedburner URL is what you tell folks to use to subscribe to the podcast with).



    Gidday up there. Weekend weather was a bit wild and windy down here, otherwise all good. Hope your weekend went well for you too :) The address that I used for the iTunes subscription test was initially the Feedburner feed address of http://feeds.feedburner.com/PukekoheCommunityChurch-SharedMessagesPodcast , but then in the process of error elimination, I changed it to the “original” feed of http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed
    End result in the test was the same either way, with test pass as far as iTunes was concerned, but zero episodes subscribed. I’m pretty sure that the fault must be mine, but do not know what I am doing wrong? The title of the subscribed podcast when shown in iTunes is
    Pukekohe Community Church – Shared Messages » podcast but in Feedburner it is Pukekohe Community Church – Shared Messages
    How do I stop it from displaying the bit at the end in iTunes? ( » podcast ), that is, after we get it to show the episodes.



    It was wet! I’m in Austin; one area of town had 11 inches in 7 hours—a quarter of our annual average rainfall! No arks needed…yet.

    When you edit your podcast at Feedburner, click on “Edit Feed Details…” and ensure the following settings:
    Feed Title: Pukekohe Community Church – Shared Messages
    Original Feed: http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed
    Feed Address: (whatever you like, but something like “PukekoheCommunityChurch” should be fine. Shorter may be better if folks ever need to manually type it in.

    Then click the Optimize tab and make sure the “Create podcast enclosures from…” option to set either to any rich media file or audio files only.

    After saving all of that, subscribing using the FeedBurner link should work in iTunes (may need a little time to let the caches reset).

    Can you let me know once you’ve done/confirmed those things?



    All checked. Only change made was to the Feed Address name which I shortened up to your suggested option. Podcast enclosures were already as you asked although it had dropped the category for some reason and so I reinserted it as “Religion and Spirituality”, subcategory of “Christianity” I’m not sure if there is an issue with our feed or Feedburner, but any editing of the feed at the moment generates a “Trouble at the Mill!” message when changes are saved. Hopefully that will take care of itself, as it suggests?


    Might pay to start collecting wood though. At least enough for a raft ;)



    Hopefully so.

    I did notice that I’m seeing something slightly different on the feed’s FeedBurner page now: https://cloudup.com/cO1e3F5szaI

    Before it wasn’t telling me that it was rich media and highlighting iTunes as an option.

    At the moment, I think it is a FeedBurner issue. Maybe let’s give it a few hours or a day, then try again to shorten the name?


    Sounds good. What time do you usually finish up for the day? I’m going to be away from having internet access from later this evening until about this time Friday (NZDT) . (its 10am Tuesday here)



    Today, I’ll wrap up a little after 17:00 UTC-5 or in about an hour.

    It sounds to me that everything is set correctly. I’ll try to subscribe via iTunes again first thing tomorrow morning and see if there is anything else on my end I can test if it isn’t working.


    Thanks Brandon. Were UTC +13 so should be able to check back on Thursday between 1 and 5pm your time.



    Looking forward to it! Have a great week in the meantime.


    Hi Brandon. Hope your ark building is still on hold and plenty of sunshine about :) Just back into internet reception and checked the site with mixed results. Feedburner now responding to editing ok, and so have successfully changed the Feed Address to “PukekoheCommunityChurch” on the edit page. This is not reflecting anywhere else though, but assume that it will after a period of time? iTunes option is still showing, as is the comment re rich media, however, iTunes still shows zero episodes and the following errors are showing on the Feedburner podmedic. 1)Media enclosure not created because: The content type returned from your host server was a text type, not a binary media type. Podcast content should always return a binary media type, such as audio/mpeg for audio, or video/mpeg for video. and 2) Media enclosure not created because: The URL was unavailable or FeedBurner could not receive a response within 10 seconds. Error #1 is shown twice for each episode followed by error #2 five times for each episode and then error #1 again, for each episode. Bad hair day, or straight forward fix??



    I’m diving into a few things to see if I can get to the bottom of this.

    The ground is still wet, but the ark project is a few notches down on the list. :-)

    I’ll give you an update in a short bit.

The topic ‘WordPress RSS feed not working.’ is closed to new replies.