WordPress reader feed showing links to old domain and not the new one

  • Author
    Posts
  • #3518829

    Hello there,
    Recently, I changed my domain name from justiceandpolity.com to justicemirror.com.
    Everything is fine except that links on my WordPress reader feed are taking to the old domain URLs on click and not the new one.
    For instance, the WordPress reader feed (https://wordpress.com/read/feeds/106865935/posts/2774384647) when you click on ‘VISIT JUSTICE AND POLITY JOURNAL’ for the full post, it is taking to old domain URL of that post (https://justiceandpolity.com/the-pandemic-the-migrants-and-the-delayed-justice-of-the-supreme-court/) and not the new one which is https://justicemirror.com/the-pandemic-the-migrants-and-the-delayed-justice-of-the-supreme-court/
    Please help me resolve this issue at the earliest.
    Thank you!

    #3519276

    supernovia
    Staff

    Hi, can you ensure you’ve set the site’s new URL under your General Settings, then disconnect and reconnect Jetpack? On our end it’s still showing the old address.

    #3519532

    Hey, I did that, but still, the WordPress reader feed shows the old URLs and not the new ones.
    I would be grateful if you can help further.
    Thank you

    #3519594

    fstat
    Staff

    Hi there,

    I have updated the Reader feed and now all the posts in the Reader point to the new URL.

    #3519663

    Hello sir,
    Thank you so much for your efforts. however, not all posts URLs have been updated to the new domain on the WordPress reader feed.
    Only the URL’s of 10 latest posts show the new site URL. Moreover, similar posts with old URLs also exist side by side. so I have two copies of these 10 latest posts on the reader feed. one copy shows the old URL and the other one shows the new one.
    In addition to this, remaining posts are still showing the links to old domain URLs and not the new one.
    Please help.
    I look forward to hearing from you soon.
    Thanks and warm regards!

    #3519779

    fstat
    Staff

    Only the URL’s of 10 latest posts show the new site URL.

    Yes, that’s how it works. Only the last 10 posts are pulled by the Reader. I can clear the older ones (that point to the old URL), but I need your confirmation on that.

    #3519830

    First of all, that you so much for this help and support. It means a lot and I am so grateful to you.

    Yes, you may kindly clear the old ones while ensuring the new ones remain as it is with all their data, i.e. content, comments, etc.

    Also, kindly note that when I access my feed by clicking my comment or like in someone else’s post on the WordPress reader feed, then all my posts show the new URLs and there is also no doubling of posts. However, if I search my site in the reader feed and then click on it, then it still shows a copy of some latest posts with both old and new URLs.
    Please resolve this issue as well.

    Also note, that from the settings, I have increased the number of posts display in the reader feed from 10 to 100.

    Warm regards!

    #3519911

    macmanx
    Staff

    I have refreshed your feed’s cache, which should take care of this.

    It’s looking good on our end now. Is there any improvement on your end?

    #3520297

    Hello,

    Thank you so much.

    All posts in the reader feed now show links to the new URLs and I no longer see any duplicate content therein.

    Thanks so much again for this help and support. It means a lot and I am so grateful to all of you. I am also deeply impressed by your sincerity and dedication in resolving these issues on this WordPress support platform. It’s indeed a community of wonderful people here. You all are awesome.

    May the Almighty bless and guide you all immensely.

    Stay safe and well.

    Best wishes and warm regards!
    Atul

You must be logged in to reply to this topic.