Wordads Ads Over My Blog Content

  • Author
    Posts
  • #3186919

    Hello,

    I’ve been blogging with WordPress for almost six years, and have been with Wordads for about a couple of years. I had no issue with placements of ads on my blog until this week – what’s happening is the ads are being placed over my blog content, interfering with pictures and text. Here is a link to illustrate the problem:

    https://themabelkwong.files.wordpress.com/2018/09/wordads1.jpg

    As you can see from the link, the title and the few sentences of my blog post is cut off.

    I have the custom domain and CSS upgrade on my blog, and have used CSS to tweak my blog’s template here and there.

    Can anything be done regarding the placement of the ad on the left which is blocking my blog content?

    Thank you very much.

    Mabel

    The blog I need help with is mabelkwong.com.

    #3187405

    fstat
    Staff

    Hi there,

    I don’t see any ads overlapping your blog’s contents and as you can see from the following screenshot, the vertical banner ads are displayed on the right sidebar and not on the left:

    http://cld.wthms.co/SnOn4Q

    Can you please check the following in case there’s something wrong with your web browser?

    * Clear your browser’s cache and cookies:

    https://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

    * Check that you’re using the latest version of your browser:

    http://www.whatbrowser.org/

    * Try another browser:

    https://browsehappy.com/

    If all of the above doesn’t work or you have more questions, just let me know and I’ll be happy to help!

    #3187459

    Hello!

    Thanks so much for responding, and for your suggestions. I tried them: updating my Firefox browser (which was out out of date), cleared my cookies and cache, tried looking at my blog in another browser (Internet Explorer). The problem still persists. I’ve attached a screenshot of how my blog looked a few moments ago:

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-28-09.jpg

    I do notice if I minimise my browser’s screen (to occupy half of my screen), ads don’t show on the left or block my content:

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-28-09-02.jpg

    I’m not sure what the issue is, but I’m guessing it could be an issue with the customise CSS code that I wrote.

    Happy to hear any suggestions or thoughts you might have. Once again, thank you so much.

    #3187698

    I do notice if I minimise my browser’s screen (to occupy half of my screen), ads don’t show on the left or block my content:

    At what size do you start to see the issue happen?

    I am asking because when I work from my 13 inch lap top I’m not seeing the issue described.

    PS – that’s a lovely water color on the site :)

    #3187962

    Hi Liz,

    Thanks for the response. I’m not sure how to find the size of the window as I minimise it. I tried Googling on how to do that, but I can’t seem to find out. Maybe I’m looking in the wrong place?

    I had a look at my blog again today and the issue still persists.

    PS – Thank you. I had the watercolour commissioned and the artist did a great job :)

    #3188099

    kokkieh
    Staff

    Hi there,

    You can use https://www.whatismybrowser.com/ to find your browser window size.

    Additionally, are you seeing a banner ad above the header image at the top of your site? Does an ad ever load in the sidebar on the right, or does that ad slot remain blank for you as in your screen shots?

    I’m not sure what the issue is, but I’m guessing it could be an issue with the customise CSS code that I wrote.

    Unlikely, because then we’d have seen the issue as well. But it’s easy to test – try removing your custom CSS and see if that makes any difference.

    Going by your screen shots it also looks like this isn’t a single ad, but that it’s happening with different ads, correct?

    #3188333

    Hi Kokkieh,

    Thanks for that. That link is handy.

    I am seeing a banner above the header image. The ad on the sidebar also does load. From my screenshots these look blank, but these ads take time to load – probably due to internet connection speeds over here.

    Here is how my blog looks full-sized, ads over blog content (screenshots below include browser size):

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-full-size-01.png

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-full-size-02.png

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-full-size-031.png

    I then slowly resized my screen until I see no more ads over the content:

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-minimise-011.png

    https://themabelkwong.files.wordpress.com/2018/09/screenshot-minimise-021.png

    Taking out the CSS completely brings my blog back to the original Twenty Eleven theme. The blog posts / texts in the middle of the page shrink in width, and the ads don’t seem to be blocking anything. But given the content that I write (rather lengthy essays), a wider width for posts works better – hence the CSS.

    I’m not sure what you mean by happening with different ads. Wordads has put multiple ads around my blog. but the ad on the left (as per the screenshot) is the only one blocking my blog content. Any suggestions?

    Thank you so much for your time. Really appreciate it.

    #3188493

    bdukes
    Staff

    Hi there,

    As you’ve noticed at certain widths we do show a fixed ad on the left of the page. In your case since the width of the page is wider the fixed ad may cover content.

    A simple workaround here would be to use media queries to add padding at just the 1300px width and above. I took a quick guess and landed on 150px of padding.

    Give this a go above your other custom CSS and if needed you may add !important to the rule.

    @media all and (max-width: 1300 ) {
      #page {
       padding-left: 150px;
      }
    }
    #3188884

    Hi Bdukes,

    Thanks for the suggestion. I put that into my custom CSS, with and without the !important tag, and there is ad still covering my blog content. I also added a ‘px’ after max-width: 1300 and that didn’t change anything.

    I also tried inserting ‘padding-left: 150px;’ into other @media components to see if that does the trick, but to no avail.

    Should I be adjusting the ‘150px of padding’? Any suggestions welcomed.

    Thank you so much.

    #3190214

    Hi themabelkwong,

    Thanks for giving that a try. I’ve asked the WordAds team to take a closer look at the overlap issue with your content and I’ll be in touch again when I’ve heard back from them.

    #3190700

    Hi gemmacevans (and all),

    Thanks for the response and for assisting. Very much appreciated. We’ll await WordAds’ response then :)

    Mabel

    #3190707

    Also FYI:

    It seems the WordAds are appearing on the left of my blog too, covering the content (looks like it’s either on the left or right). Here’s a screenshot of my blog from today:

    https://themabelkwong.files.wordpress.com/2018/10/screenshot-04-10.png

    Thank you!

    #3191053

    Sure, I’ll let you know as soon as I have more news. Thanks for the additional screenshot too :)

    #3206606

    As of this week, it looks like ads are no longer covering or overlapping my blog’s content. Perhaps WordAds had a look and resolved the issue.

    I’ll mark this thread as Resolved shortly (and if the issue crops up again, I”ll un-resolve it).

    Thank you everyone :)

The topic ‘Wordads Ads Over My Blog Content’ is closed to new replies.