Why is my site suddenly so slow?

  • Author
    Posts
  • #2007364

    gwmac
    Member

    I spent weeks optimizing my site. I read dozens of guides and tutorials to get the best settings for W3 total cache and all my other plug-ins. About two weeks ago I finally managed to get very good scores on Gtmetrix, Google PageSpeed, and also the http://tools.pingdom.com/ site. Scores above 93 desktop and 80 mobile on Google. I thought all the hard work had paid off but that fast speed only last about one week. I am now getting 49 mobile and 63 desktop scores on Google.

    I have not installed any new plug-ins. Everything is updated to the latest versions. What is worse is that even my own admin-page is slow to load. When I click on dashboard or really any item available on my admin sidebar at times it can take sometimes 5 or more seconds to load the page.

    I am at my wits end as to what is causing this slowdown. I have no idea if the slowdown is on my end or server side. Could some of you wizards with far more experience take a look and see if you can help me figure out some changes I can make to speed things back up?

    I will be more than happy to provide you with any other details you need to help me figure out why my once super fast website suddenly has a flat tire. I am a novice user but learn quickly and can follow instructions. I see all the errors on these benchmark scores but am not clear how to fix them and which are the real priority to fix. I saw similar errors as well when my site was blazing fast so I have no clue which ones need are responsible for slowing things down the most.

    Thanks in advance for any help.

    http://gwmac.com/

    Here are the test I used:
    http://gtmetrix.com/reports/gwmac.com/JMHDqWRx

    http://tools.pingdom.com/fpt/#!/bzpoSO/http://www.gwmac.com

    https://developers.google.com/speed/pagespeed/insights/?url=www.gwmac.com&tab=desktop

    The blog I need help with is gwmac.com.

    #2007432

    gwmac
    Member

    well, I can confirm it is definitely a plug-in causing the problem. I disabled them all and my scores shot up to 95/100 on kingdom and 72/100 mobile 90/100 desktop on Google.

    So my question is how to find the plug-in(s) causing the slow down. Enabling them one by one and re-testing will take a long time. Here is my full plug-in list so maybe some are incompatible or known problems.

    All the plug-ins below are the latest versions. If some are not needed or cause conflicts I appreciate an analysis of what plug-ins I should consider deleting or even recommendations of ones I need to install.

    Askimet
    All In One Favicon
    easy Photo Album
    Facebook
    Fast Secure Contact Form
    Google Analytics Dashboard for WP
    Google Publisher Plugin
    Google XML Sitemaps
    GTmetrix for WordPress
    Iframely
    iThemes Security
    Jetpack by WordPress.com
    P3 (Plugin Performance Profiler)
    Pizazz
    Polls by OpinionStage
    Quick Page/Post Redirect Plugin
    Sucuri Security – Auditing, Malware Scanner and Hardening
    Ultimate Tag Cloud Widget
    UpdraftPlus – Backup/Restore
    Use Google Libraries
    Verify Bing Webmaster Tools
    W3 Total Cache
    Weather for us widget
    Welcome to WordPress
    Wordfence Security
    WordPress SEO
    WP-Optimize

    #2007439

    gwmac
    Member

    OK sorry for all these posts but I wanted to document this as I worked and hopefully this might help someone else with a similar problem. I think I solved the problem.

    Under Jepack sharing settings I had the “Show Buttons on” Front, page, archives, and search results clicked. On my homepage there are around 15 or so articles showing which means it had to load the Facebook, twitter, Reddit, etc..icons for all those 15 articles. I simply unchecked that and just show the icons on the posts and pages and now my site is fast again.

    Even now it is not quite as fast as I would like. It is at least a functional website again and people do not need to wait 5 to 10 seconds for the homepage to load.

    I would still appreciate the expert opinion of someone that can analyze my site for possible speed improvements as well as an analysis of my plug-ins for potential issues and any recommendations for ones I should deactivate or possibly others not installed that would be beneficial.

    #2007440

    kokkieh
    Staff

    I’m afraid you’re in the wrong forum. This support forum is for free WordPress.com blogs. You appear to have a self-hosted WordPress.ORG install. WordPress.com and WordPress.org are completely separate and different: http://en.support.wordpress.com/com-vs-org/

    Please visit the WordPress.org support forum for assistance as we won’t be able to help you here: http://wordpress.org/support/ If you don’t already have a username on that forum, click the register button in the upper right corner so you can post in that forum.

    #2007441

    gwmac
    Member

    sorry didn’t notice this was the com and not org side. thanks

    #2007442

    kokkieh
    Staff

    No problem. Hope they can help you over there.

The topic ‘Why is my site suddenly so slow?’ is closed to new replies.