Upgraded to Business Plan – All pages with [display-posts] shortcode broken

  • Author
    Posts
  • #3068673

    I upgraded to the Business plan about an hour and a half ago and installed two plugins before I noticed that all of my pages with display-post shortcode showed code instead of listing posts (see below). I disabled both plugins and there’s no change. An example page is here: https://pragmaticcompendium.com/recent-posts/

    this is what shows on that page since the upgrade:
    [display-posts author=”pragmaticcommunication” image_size=”thumbnail” wrapper=”div” posts_per_page=”50″ include_date=”true” order=”DESC” orderby=”date” include_excerpt=”true” ]

    What happened? Do I have to cancel my Business upgrade and go back to premium?

    The blog I need help with is pragmaticcompendium.com.

    #3068821

    Spent a few hours with online support chat and got my site back to pre-upgrade status. I had to install a shortcode plugin which repaired MOST of my [display-posts] shortcode : https://wordpress.com/plugins/display-posts-shortcode

    One thing I figured out and something to look for in broken [display-posts] code is the shape of the quotes. Code needs straight quotes. The upgrade somehow changed some (not all) of my [display-posts] shortcode taxonomy to something called smart quotes, which are quotes that curl inward toward the quoted text. I replaced the smart quotes with straight quotes.

    The upgrade reset a bunch of widget content to previous states so I had to do some editing. Not too bad.

    Also, any “hidden” widget content was reset and – at least in my case, using the Edin theme – there’s no way to hid it. Every option has a red X next to it. I just deleted the widgets instead of hiding them. If want to use them again, I’ll need to recreate them.

    #3068839

    fstat
    Staff

    That’s good to know and thank you for the update!

The topic ‘Upgraded to Business Plan – All pages with [display-posts] shortcode broken’ is closed to new replies.