RSS Feed Problems

  • Author
  • #2344575

    Written 05/Apr/15

    After 2 days searching this forum and elsewhere on the web,changing theme, changing, headings, changing text etc. I am tearing my hair out.

    I only have a simple on-line blog

    I want to add it via an RSS feed to a web forum.

    I got an error message: RSS feed error: XML error: undeclared entity error at line 10.

    <<Edit 6/Apr/15. Having tried yet another theme – one I see has been linked successfully to the same forum – I now get: Could not load the RSS feed Code: 301.

    I also got this error when I tried using /feed/atom as suggested in the answer to another post.>>

    I checked the url through feed validator at and get:
    This feed is valid, but interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

    •line 27, column 142: Unregistered link relationship: search (2 occurrences) [help]

    … om/osd.xml” title=”Tales from TheRSR” />

    Line 27 read as follows: <atom:link rel=”search” type=”application/opensearchdescription+xml” href=”” title=”Tales from TheRSR” />

    I have no idea what all this means. All I want to do is publish my blog to the website above. I see that other WordPress sites are linked to the website for example:

    Would really appreciate any help. Please bear in mind that I am a very simple and, (increasingly hairless) user! :-)

    Many thanks


    The blog I need help with is


    Hi RichardS!

    Just to clarify, when you’re receiving the “XML error: undeclared entity error at line 10” issue, what URL are you entering for your feed? It should be

    The feed seems to be loading correctly so I’m not sure why this is pulling up an error. Let’s make sure we’re using the correct URL, and then we can troubleshoot a bit more from there!


    Hello Jeremy, thank you for your response. Much appreciated.

    Yes I was using the correct url. In fact even if fail to put /feed the site I am hoping to add the feed adds it. As mentioned in my op I even tried /feed/atom to no avail.

    I just tried again and the message is now: Could not load the RSS feed Code: 301

    Since the original error I changed the theme to one I see another user has successfully fed into the forum. This theme is The Digg 3 Column.

    I have also just checked with RSS validator and the line 27 error is still showing.

    Thanks again


    Hey Richard,

    The error you’re referencing (should read “Unregistered link relationship: search”) isn’t anything to worry about. You’ll see this warning on many sites. It shouldn’t affect how your feed is loading though. The 301 is more puzzling. That generally means something has been moved permanently but your feed has been and always will be in the same spot. Could you take a screenshot of the screen where you’re inputting the feed URL and the error you receive? Just upload those screenshots to your media library so I can take a peek. Screenshot instructions can be found here:


    Jeremy, thank you.

    As my screen does not show the whole web page (small laptop) I have created a pdf of the screen you asked for and made it available in Dropbox.

    The url is :

    I hope this is ok.


    Thanks for sending this over Richard! Can you try setting up the feed in Feedburner and see if it comes up with the same error? To setup Feedburner, follow these steps:

    1. Start on this page:

    You will need to be signed in with your Gmail account.

    2. Enter your blog address into the field shown here:

    You will just need to enter the following URL:

    3. You should see an option like this:

    Click “Next” and select your main feed (not the comment feed).

    4. Click “Next” and title your feed as well as provide the URL where the feed will be found. For example, it could be

    5. Click “Next.” You should now be presented with a URL from Feedburner that represents your feed. Can you try this URL in place of the feed URL?


    Jeremy, that has worked. :-)

    I won’t pretend to understand why!

    Thank you very much for your help.


    Excellent! I’m not exactly sure why either. I suspect it was an http/https issue. Your feed is sent over https. The Feedburner feed is sent over http. Judging by the tip on that screenshot you sent over (regarding http), I think that was the issue.


    I had tried using http://….. rather than https://…. but presume that didn’t work for obvious reasons. Are all WP sites https?



    All WordPress.COM hosted blogs on sub-domains (not one their own domains) do have the more secure https:// URLs.


    All WordPress.COM hosted blogs on sub-domains (not one their own domains) do have the more secure https:// URLs.

    Spot on! :)

    @richardslipper – We automatically redirect the http version to the https version for URLs.


    Which makes sense but would mean that anybody trying to do what I was doing should have the same problem in the same circumstances.
    I’ve added the solution found to a suitable thread on the forum concerned so hopefully others will not have the same difficulty that I encountered.
    We live and learn.
    Thanks guys.


    Hope you’re still picking this up Jeremy. But another problem has now surfaced. (It makes life interesting!)

    While the link is now working to the forum, the blog posts I have made since linking the sites are showing the html code on the forum.

    Blog posts I made before linking the sites are appearing clean.

    Any ideas?


    Could you grab a screenshot for me and upload it here?

    I’m wondering if this is a setting we missed through Feedburner.


    Hi, you should find a jpg in the media folder called HTML Example (1). Hope it’s ok.

    Incidentally, another of the target forum members has commented on my post quote << I don’t like WordPress pages posted on RMWeb!?>> Maybe there is a wider problem although I myself haven’t noticed it.


    Thanks Richard. I actually found the forum post here:

    I’m a bit stumped on this one. It looks like doesn’t like the Feedburner feed at all. However, it doesn’t like the feed because of the HTTP/HTTPS issue either. I double-checked all over Feedburner, but I don’t see a setting that would be causing this.

    My best suggestion for right now would be to try to add a custom domain to your site like (or whatever you would like). The main benefit here is that we can’t secure custom domains so it would have an HTTP prefix for the feed. Are you open to giving that a shot? If it doesn’t work, we can always refund and remove the domain.

    If you’re up for giving it a shot, follow the steps here to register your domain:

    Then, once you do that, remove the feed we currently have in place and replace it with Can you give that a try?


    Thanks for that Jeremy.

    I think I’ll refer the problem with the forum’s tech guys first. It’s not good enough that a) they don’t seem to accept https when it has to be the preferred protocol, b) they don’t like WordPress via Feedburner – they are not exactly niche products/services.

    They must have encountered the matter before.
    I’ll post here when I hear from them (if I do!)



    Well somebody has responded with a question……Is there a reason you are running all your blog through an SSL (https) connection? Does not give you an option to turn it off (or only run parts of the blog through https)?

    IIRC there is no option.


    Hey Richard,

    There isn’t an option to turn off HTTPS I’m afraid. We force all site URLs to HTTPS. It provides a more secure browsing experience. It looks like it also gives sites a bit of a boost in Google searches:


    Thanks Jeremy, I thought that was what you said before.
    Curiously nobody has yet ‘picked up’ my tech question to the forum.
    We shall see. :-)

The topic ‘RSS Feed Problems’ is closed to new replies.