Remove Social Media Icons on ONE Page

  • Author
    Posts
  • #3215138

    akumm
    Member

    I would like to remove the social media icons on this specific page but for some reason I can’t see a place for me to do this in the editor. I know I have done it before on other pages, but for some reason I am having a bit of difficulty.

    https://annmariekumm.com/resources/

    The blog I need help with is annmariekumm.com.

    #3215255

    musicdoc1
    Member

    Hi,

    See the Disabling Sharing / Likes On Specific Posts section of the Sharing support page. It applies to pages as well as posts.

    The check boxes for showing or not showing sharing buttons and likes may be found in each post and page editor at Post/Page Settings > Sharing.

    #3216277

    akumm
    Member

    Thank you for the link, but I am still not seeing an option to edit on a per page basis.

    Here are screenshots of what I am seeing: https://drive.google.com/file/d/1iv6V83ez0RVEXPK421uufnjRRLyo5CXl/view?usp=sharing

    https://drive.google.com/file/d/1ByMjftdiMiqokYV_ZJaTuhZh4-ngfrQI/view?usp=sharing

    #3216284

    justjennifer
    Moderator

    Hi there, click the “Screen Options” in the upper right corner of that screen and make sure that the Likes and Shares module is checked. (temp screenshot) Then in the module, which will appear at the bottom of the editing screen, if the “Show sharing buttons” line is checked, uncheck it and update your Page.

    #3216292

    akumm
    Member

    Thank you! Only issue is that I do not have that as an option. https://drive.google.com/file/d/1TVdb1otMhd5r3L71sGF5ViOR66HoFIm5/view?usp=sharing

    #3216300

    akumm
    Member

    Note I switched to the Gutenberg editor. I think this may be the issue. It doesn’t seem to be an option with this editor, or am I missing something?

    #3216309

    justjennifer
    Moderator

    I’m not certain, so I’ve flagged this thread for Staff attention and assistance. I do see in your screenshots (in the URL) that you are editing in the “classic editor” for this page.

    #3216319

    justjennifer
    Moderator

    Yes, that looks to be the issue. I just opened one of my test sites which has the new block editor enabled and chose “Classic Editor” for editing an existing Page and the Likes & Shares module is not available in Screen Options. (temp screenshot)

    Let’s wait for Staff input here.

    #3216336

    Correct – these options are not moved over in to Gutenberg quite yet. You’ll have to switch back to the classic editor in order to adjust your sharing settings for a post or page.

    Find the ... in the upper right corner of the screen, and click on it. The last menu item that pops up is switch to classic editor. Use that link. Let me know how that works out.

    #3216409

    justjennifer
    Moderator

    Hi @lizkarkoski-we are both using the Classic Editor mode to edit our Pages, but the “Likes & Shares” check box in Screen Options is missing. On a site where the the new block editor was not enabled, that check box appears.

    Screenshot of Screen Options on site where the block editor has not been enabled at all.

    Screenshot of Screen Options on site where the block editor has been enabled, but the Classic Editor is being used.

    and https://drive.google.com/file/d/1TVdb1otMhd5r3L71sGF5ViOR66HoFIm5/view

    #3216623

    supernovia
    Staff

    I can’t seem to duplicate this, even on a site where I’m constantly switching back and forth between editors.

    I’m seeing likes and shares at the bottom of your page, @akumm, though it is at the very bottom right now, in one of the boxes that’s the same width as the post.

    Are you seeing that? It’s just above Thank you for creating with WordPress .

    And @justjennifer if you’re willing to share which site you’re testing with there I could take a look at it too.

    #3216909

    justjennifer
    Moderator

    Hi @supernovia

    agallerydemo.wordpress.com – Gutenberg enabled, but using the Classic Editor option in WP Admin to edit a Page. No “Likes & Shares” check box in the Screen Options dropdown.
    https://screenshots.firefox.com/Vgeo8nyzKhxEpxj0/agallerydemo.wordpress.com

    muzaphoto2017.wordpress.com – Gutenberg not enabled, so using the original “classic editor” in WP Admin to edit a Page. “Likes & Shares” check box visible in Screen Options dropdown.
    https://screenshots.firefox.com/lhjZK6C8NeROy4Is/muzaphoto2017.wordpress.com

    Using FF 63.0.3 (64-bit) on a Win10Pro PC 64-bit

    Thanks for looking and happy Thanksgiving.

    #3217064

    kokkieh
    Staff

    Gutenberg enabled, but using the Classic Editor option in WP Admin to edit a Page. No “Likes & Shares” check box in the Screen Options dropdown.

    I can replicate this. What’s likely happening is that Gutenberg is completely disabling the sharing settings in the editor, so even if you open the post in the classic editor, the fact that Gutenberg is enabled means that module simple doesn’t work.

    We are working on adding support for the sharing module to the block editor, but for now you’ll need to disable Gutenberg entirely to have access to that module.

    I’ve reported this in the existing issue on missing sharing options in https://github.com/Automattic/wp-calypso/issues/28528, just in case.

The topic ‘Remove Social Media Icons on ONE Page’ is closed to new replies.