Recent posts title issues?

  • Author
  • #3390141

    Hi, pretty new with WordPress, would appreciate help mostly with blog posts/news.

    When displaying them on the page, 4 recent posts do not show title. They start with the first sentence and end with Continue reading. Is there a way to fix this, to include their titles and link those to full posts (must be possible :))

    Thanks so much!

    The blog I need help with is



    Hi there, is this the page you are referring to? If so, I see the post titles of each post there, the last from November 1st 2019. On that page there is a “Read More” link to the full post for each post.

    However, I do see that the post titles on individual posts do not display. Is that what you are referring to? Is it possible you have custom CSS that hides their display?

    I also note it looks like you have a paid plan, so you are also eligible for direct support by LiveChat and email when you post at https:/

    Let us know if you need more help with this here in the community forums or have gotten assistance by direct support. Thanks.


    Hi, sorry – should have specified, I was referring to the Homepage.

    But yes, there is another issue I have with post titles on individual posts, they don’t display. I am not sure which CSS I have, any tips on how I can check it?

    I would prefer to continue talking here, if ok :)
    I found the forum super useful, so might help someone else experiencing the sane issues



    Hello again, If you haven’t added any custom CSS to your site, you’re using the theme’s default CSS. You can learn more about your theme’s CSS from this guide:

    Regarding the Recent Posts section on your homepage, I see what you mean, and that seems to corroborate the issue of your individual posts not displaying the post title.

    If you look at the Karuna demo site at and scroll down to the “Recent Posts” section there, you’ll see that each post has a post title which serves as the link that brings the reader to the full post when clicked. For whatever reason, your posts do not display a title in the Recent Posts section of the front page nor in single post view.

    However, the page at does display the post title.

    Let me flag this thread for Staff attention and assistance as well.



    Forgot to mentoin that if you did add any Custom CSS to your theme, you’ll find it in the Customizer>CSS


    Good Morning –

    Getting up to speed here. So, when looking at the home page, under recent posts I see the posts there are listed with out a title.

    If I select the read more option from that section the entire post opens up. Like this: Again, there is no title displayed.

    Then, when I go to edit that post, I see there is actually a title set. It’s Earth observation and the legal community, a missing link.

    Looking at the theme demo I can see that there are titles on the recent posts section.

    I will continue working on this to see if I can figure out why your post titles are not displaying.


    Found it. There’s CSS on the site that’s been added which is hiding your post titles.

    Go to My Sites – Design – Custmoize – CSS

    Locate and remove this portion:

    .entry-title {
        display: none;

    Save the changes. Once you do that the post titles will be displayed again.



    Terrific! Thanks @lizkarkoski :)


    Thanks a million! It worked :) Not sure who added it there and why – will check with colleagues.
    Another minor issue I have is that the button Recent posts at the Homepage button doesn’t lead to the “News” section. Any advice on how can I link it?


    Recent posts at the Homepage button doesn’t lead to the “News” section. Any advice on how can I link it?

    That section on the homepage comes from your theme, Karuna, and if you check the demo you’ll see that the Recent Posts text at the top is not clickable. The button More Posts on the other hand, should lead to your blog page. For that to work, try to set your blog page to News from My Site>Design>Customize>Homepage Settings. You’ll notice that no page is selected as the posts page right now.

    I hope that makes sense :)


    Hm, tried to change My Site>Design>Customize>Homepage Settings Posts page from “-Select-” to “News”. If I change the whole Homepage changes to “News”.

    Did I understand correctly?
    Thanks for your time :)



    Hello again, there are two settings in the Customizer’s Homepage settings. One is setting your static front page as your site’s homepage and the other is selecting which page is your blog page. See the illustration here>

    Let us know if you have any other question about this.


    Not quite. So, the setting that my colleague mentioned is designating which page you’re posts are going to be published on. Changing that to “News” means that the posts will publish on to the “News” page.

    The front page of your blog, the one that folks see first when visiting, would need to be reassigned to a different page. By default your posts are displayed on that front page, but you’re making an adjustment there so it needs to be replaced.

    Does that help?

    You’ll need to designate the Post Page and the Front Page of the blog now. If still having trouble just write back and tell us which pages you’d like to designate for each setting and we can set that up for you.


    Oh. This seems very complex to me. A colleague set this website up, so it would take me quite some time to read through the explanations and instructions you shared.

    I would just (well, “just” as I have no clue how long it will take to set this up) like the “More posts” button displayed at the end of Homepage, under the 4 posts, to link to the page called “News”. If you can help great, otherwise I will do it sometime later (too afraid to mess up the whole website while testing how it works)

    In any case, thanks so much for your time and support!


    I would just (well, “just” as I have no clue how long it will take to set this up) like the “More posts” button displayed at the end of Homepage, under the 4 posts, to link to the page called “News”.

    You should be able to achieve that with what we mentioned above. Go to My Site>Design>Customize>Homepage Settings.

    There, under Post page, from the list, choose News. Just like that:

    Don’t forget to click on the blue button Publish when you’re done :)


    Yes, yes! All good :)
    Thanks so much to all of you, and have a wonderful day

The topic ‘Recent posts title issues?’ is closed to new replies.