Problems with images and Attachment page / Custom URL settings

  • Author
    Posts
  • #2996346

    theretiredengineer
    Member
    Original poster

    I have a slightly strange problem with image links on my blog that I’ve been unable to solve. The sequence of events is as follows:

    1. Create a post including some images
    2. Set all the images to link to “Attachment page”, all looks fine in “Preview”
    3. Set a scheduled publish date for the post
    4. When the post is published then all the image links revert to “Custom URL”. The images display OK
    5. If I edit the post again to reset all links to “Attachment page” then it works and everything is fine

    Can anybody give me any hints as to what happens when the post is published? At the moment I’m working around this by editing the post once it’s published but I’d really like to fix it permanently.

    Thanks
    John

    The blog I need help with is: theretiredengineer.wordpress.com

    #2996630

    koulovat
    Member

    Hi John,

    I’m sorry to hear that you are running into this issue. I’d like to see the issue in action so that I can better investigate what may be going on here. Can you send over a screenshot of what you are seeing so that I can a closer look at one specific example? I want to be certain that I understand exactly where this is happening on your site.

    Thanks for your help!

    #2996631

    justjennifer
    Member

    Hi Nicole – Thanks for helping out here. I’d like to make you aware that this thread was tagged for Staff assistance as someone added the the MODLOOK tag to the tags section in the sidebar.

    Generally speaking, but not always, Staff look in on modlook-ed threads in the order that they were tagged for their attention and so this thread was now pushed down in their queue due to the replies. That’s not to say we shouldn’t try to help the user, but do please be aware of the tag.

    Also, if you haven’t yet seen it, please take a moment to review this helpful guide for Forum Volunteers. https://en.support.wordpress.com/wordpress-com-volunteers/ If you have any question, do please open a new thread.

    Again, thanks for helping out.

    #2996632

    justjennifer
    Member

    Hi @theretiredengineer If I remember correctly, the Add Media screen “remembers” your last applied choice for attachment setting. I understand from your above description that the post that published was a scheduled post. Is that correct? Do you recall what your previous published post used?

    I will also experiment later and let you know the results of my test.

    #2996645

    theretiredengineer
    Member
    Original poster

    Thanks for the responses.

    For each image in a post I specifically set “Image Details > Display Settings > Link To” to be “Attachment Page”. I check to make sure that it’s OK using “Preview” then I schedule the post.

    After the post is published then for each image “Image Details > Display Settings > Link To” is somehow reset to “Custom URL” instead of “Attachment Page”. However I can then manually edit it back to “Attachment Page” and everything’s fine from there on.

    ( For my clarification, from your comment “the Add Media screen “remembers” your last applied choice for attachment setting” are you suggesting that when the post is actually published then whatever I set for “Link to” is overriden by whatever the previous post was set to? )

    I have used WordPress for a customer in a previous job and this behaviour didn’t happen there. In that case everything worked as expected.

    This is not an urgent problem so if there’s nothing obvious that springs to mind then I’ll do the following diagnostics for the next post:

    1. Capture the HTML source for the page before it’s posted and image links are correct
    2. Capture the HTML source after posting with the incorrect image links
    3. Capture the HTML source after I’ve manually corrected the links

    The next post is not scheduled until next weekend and I’d rather leave it that way. However if you prefer I can change the scheduled post date to be sooner than that.

    #2996661

    justjennifer
    Member

    In my experimenting it does appear that something has changed in regards to image insertion so I prefer to hear from Staff on this..

    Looking at your above reply, however, can you please confirm where you are creating the Post, whether in the Calypso (new) Post Editor or in the WP Admin Classic Post Editor.

    Also, do you choose multiple images at once to insert (which normally creates a Gallery) or whether images are inserted individually?

    Thanks.

    #2996663

    kokkieh
    Staff

    Hi John,

    Can you please confirm which editor you’re using, as @justjennifer asked above?

    Let’s wait for your next post to publish and then see what happens. I checked the editor and it’s set to attachment pages now, and I’ve subscribed to your site so I’ll get an email when the next post goes out, then I can check what happens.

    #2996664

    theretiredengineer
    Member
    Original poster

    Thanks for the help. Answers to questions:

    1. I use the WP Admin Classic Post Editor.

    2. I insert both single images and multiple images ( i.e. gallery ). From what I’ve seen the problem only happens with the single image. Gallery is always fine.

    Regards
    John

    #2996666

    justjennifer
    Member

    Thanks for that further information. Could you please paste a direct link to the post where this happened? Thanks.

    #2996669

    theretiredengineer
    Member
    Original poster

    It’s happened with most of them from what I remember. The latest one is:

    https://theretiredengineer.wordpress.com/2017/07/30/picardie/

    #2996670

    kokkieh
    Staff

    It looks like that one you’ve already fixed, correct? It would be best to see one where it’s not fixed yet, but I can try to replicate it as well.

    #2996671

    justjennifer
    Member

    Thanks again.

    You mentioned earlier that on your customer’s site, everything worked as expected. Did that site have the Jetpack plugin’s Tiled Galleries/Photo Carousel installed?

    Looking at the post you linked to, all the images in that post open for me in the Photo Carousel, which is the default when creating a Gallery. This includes the pictures that appear to be inserted individually, like the three images right under “Somme estuary.”

    When you say “Attachment Page” do you mean the Gallery Photo Carousel (black background) or a separate Attachment page like this? https://theretiredengineer.wordpress.com/2017/07/30/picardie/somme_estuary1/

    #2996672

    theretiredengineer
    Member
    Original poster

    Ah sorry, I’ve fixed them as the problem happened.

    The next post is scheduled for next weekend but I can bring it forward if that would help?

    #2996673

    kokkieh
    Staff

    I can wait until the next post publishes at its appointed time.

    Can you answer @justjennifer‘s question above, though? Did you insert those pictures as galleries, even the single ones? I checked your sheduled post and noticed there they also open as carousel images, rather than attachment pages like the one @justjennifer linked to above.

    Can you give us some more information on the exact steps you follow to add the images?

    #2996674

    theretiredengineer
    Member
    Original poster

    @justjennifer

    “Did that site have the Jetpack plugin’s Tiled Galleries/Photo Carousel installed?”

    Not sure, as far as I know it was effectively the same as your free WordPress sites ( i.e. what I’m using now ), although it was a few years ago.

    “When you say “Attachment Page” do you mean the Gallery Photo Carousel (black background) or a separate Attachment page like this? “

    “Image Details > Display Settings > Link To” = “Attachment Page” gives the Gallery Photo Carousel.

    “Image Details > Display Settings > Link To” = “Custom URL” gives a separate page as per your example.

    ( Is it possible to attach screenshots in this forum, it might make it easier to see? )

    #2996675

    kokkieh
    Staff

    You can upload screen shots to your media library and I can see them there.

    Can you please give the exact steps you’re following? As in “Click Add Media. Click Upload image…” etc.

    #2996676

    kokkieh
    Staff

    I’m about to sign off for the day, but will take a look again tomorrow unless you figure it out with Jennifer or another volunteer’s help before then :)

    #2996677

    theretiredengineer
    Member
    Original poster

    OK, thanks. I’ll try and put together a video of what I’m doing. It’s possible that I can’t upload it to my media library on the WP plan that I’m using but if not then I’ll think of something else :)

    #2996684

    kokkieh
    Staff

    You can also upload it to Cloudup.com (you can create a free account if you don’t have one), and then paste the link here.

    #2996692

    theretiredengineer
    Member
    Original poster

    Hmm, has something been changed on the account settings because, when I add new media, the behaviour is now slightly different. Anyway the following screen capture should hopefully explain what I’m doing.

    https://www.dropbox.com/s/j9tpgpw88p70oi5/add_new_media.mp4?dl=0
    ( Note that the drop down selections are not always shown for some reason but it should still be understandable )

    I’m not sure why the image links are initially set incorrectly but they seem to work OK after that. Of course I don’t know what will happen when the post is published. If the post publishes OK then I can live with having to edit the images twice when they’re first added.

The topic ‘Problems with images and Attachment page / Custom URL settings’ is closed to new replies.