Please help! Blog showing properly to viewers but not me!!!

  • Author
  • #2025092

    I see I am not the only one having problems of this sort: Omantel………..
    Nawras 4G is ok so might just be a speed problem (nothing new there then) so have added htpps:// in front of my address and gives me a work around for now.



    Hey folks,

    Could all of you please do me a favour? Could you all please visit the following site and let me know your results?

    Our systems folks are looking to get some additional information, and it would be great if everyone would give it a try.

    Thanks in advance!



    I have just done (or tried to) using OmanTel landline – wireless and the result….

    “This web page is not available”



    Hi – Thanks for trying. Can you please provide the details (or a screen shot) of the Chrome Dev tools network panel for this request? More information can be found here:

    Also, can you please confirm that works for you?



    https: //
    comes up with “Hello World”

    Re Chrome Dev tools network panel
    I cant figure out how to use it !



    Hi –

    Thanks for the update. It seems like your ISP or something on your local network might be filtering some of your traffic. If the problem persists across multiple browsers and computers, I would recommend contacting your ISP and reporting the problem. If they provide you an explanation, we would be interested in hearing it.


    Original poster

    lol nice to know so many people are all having the same problem….. welcome to Oman…i hope everyone’s problems are resolved…i know its hard…u do get attached to your blog :)



    thanks for the investigation.
    I think as its our (all 3 users) ISP we will unfortunately leave it as it is



    Hey everyone,

    Ynotoman, I believe there’re many users here in Oman, I’m one of them. It’s just matter of time before they realise their blog doesn’t display properly.!!

    I’m trying to contact Omantel, however I could not get in touch with the responsible team… HelpDesk are useless..

    I searched in google about the nature of this problem and found this forum!



    Hi, based from your detailed explanation of the problem and the screenshots.

    I can see that jQuery and CSS links are not properly loaded that makes your WordPress website act that way.

    The disappointing part is, the above behavior of your websites only appears when using Omantel connection, I have checked your website with Nawras and its working perfectly without https

    Here is a screenshot of ynotoman blog with the error showing in the Console

    I made further inspections and found out that the stylesheet and javascript which is located at won’t load unless you use https.

    1. is the stylesheet file
    2. is the javascript file

    Now, to get this thing working in Oman, our ISP should allow the access to

    With regards to the query of @amightywp, here is a screenshot when you open

    as you can see there is a status code of 502 when GET method is initialize.

    and here is the response header

    and of course when using https it will return status of 200 and working perfectly.

    Hope this will help :)



    So, the solution is to contact your ISP and ask them to whitelist



    Oh orphicpixel – very technical! and Impressive.
    So its a coding issue on WordPress – that dosnt show unless…… using OmanTel.

    BTW – its interesting to see that – also have the same issue as I just found out – but theirs is far worse .

    Unfortunately raincoaster, OmanTel are not especially responsive



    @amightywp & @barry
    Thanks for your support!

    I’m using two internet connection at home by different ISP
    1-OmanTel &,

    For your info, everything works well with Nawras connection, however the issue rides on Omantel only….. only (https) loads fine

    Now by doing the testing (using OmanTel connection); >>> Failed to open >>> The page loads and shows hello world

    by using the Chrome Dev tools: (I Did not use it)

    By using the developer tools in Safari browser in Mac OSX
    I did the test on my own blog
    The error console shows the following:




    Surprisingly is depending also on for their scripts and css.

    Is there any Omantel contact page where we can storm complaints with regards to this issue?



    Just asking … have you bloggers read the Staff responses in this thread ?



    tometheif – yes – Im using uptodate everything and as you see since Aug 30 we have tried various things including resetting the Cisco router thing.
    Its clearly an OmanTel issue both on Mobile and Landline – Nawras works
    orphicpixel seems to have identified the coding problem that only fails on OmanTel .
    Lets see what transpires



    Hi everyone,

    We’re doing everything we can to get this issue sorted out for you. To help us out, please make sure you’re using a computer that is unable to access this link:

    Then, go to the following link to look up your IP address:

    Please copy your IP address from that page and send us an email (to with that IP address in it.

    You can also include a link to this forum thread in your email, and let me know here once you’ve sent it. Thanks!



    Hi rachelmcr = Happiness Engineer
    an email have been sent
    thanks for all your investigation on this



    even this is not showing correctly



    It will be fascinating to see if this issue is resolved.
    Since late August it apparently has affected websites which are hosted on the servers of ‘’, not the wordpress web software specifically.
    Presumably a range of IP addresses have been affected – including major websites above.

The topic ‘Please help! Blog showing properly to viewers but not me!!!’ is closed to new replies.