Page password protection ignored

  • Author
  • #805218


    Hi Everyone,

    I’m currently converting a mockup into a wordpress website for a client. One of the pages in the navigation list is called “Students” and it needs to be password protected. Here are the steps I have taken.

    1. Create a new page “Students”
    2. In the “Publish” menu, Visibility > Password protected: “password”
    3. [ Update ]
    4. [ Preview page ]
    5. What I see is a regular page, except the title of the page is changed to “Protected: Students”
    6. The rest of the content is as you would expect for a non-password-protected page.

    I am using WordPress 3.3.1. Is this one of those “known issues” that I don’t know about? Thanks in advance.



    You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you’ll find help at the forums.

    If you don’t understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It’ll help people to answer your question.

    This is an automated message.



    i am having a similar problem! i had someone check from another computer but they couldn’t see anything until they put in the password! then evey time they open the site they can still see the page open! does anyone know if you can log out of a password protected page?



    You are posting to the wrong support forum and need to post here instead



    If you are asking about the blog linked to your username your need to contact Staff. Use the Help button on the top right hand corner of your Admin page to do that please.



    Actually, it’s because your computer is storing the password, or the cookie WP gave it once it signed in. Change the computer settings and problem solved.

The topic ‘Page password protection ignored’ is closed to new replies.