Links won’t work

  • Author
  • #3324276


    I put six images on my website. Added a link to each one. Only one saved. Trying now to add a link to the first one that. I click on the image, then click the link button. Add the link. Click open in new window. Click update. Looks like it’s doing something. Doesn’t work. I don’t know if you are supposed to have the picture highlighted with little boxes on all four corners, or just click on it once to make it work. But I tried both times and neither worked.
    I am using the classic editor. I had all of these working then I switched to the block editor and everything got messed up. I could not understand the block editor at all.
    Thank you in advance for the help.

    The blog I need help with is


    Hi there,

    I see that on the last image, it links to an amazon page successfully. I’m checking and am not seeing anything that would prevent you from adding the image link to your images without issue.

    Well, for the block editor, did you follow these instructions when trying to link an image?:

    If you are reverting back to the classic editor, you can follow the instructions here to add an image link:

    Let me know if either method works for you.




    Thank you for the help. I click on the cover for my book “Mistakes”. It highlights for a second, with a little box around each corner. Those boxes vanish instantly. I click link, add the URL, click “open new page”, click add link, click upgrade.
    Close the edit page. Open up my website, try to click on the cover for “Mistakes” nothing happens.

    How do you select what you want to add a link to? One click, left click, double click, right or left double click? Are those little boxes supposed to stay lit up at the corners so you know you are working on adding something to that? Mine light up and vanish.

    Thanks for your help.



    Hi, It’s me again. It seems to be working alright now. Whatever you did to clean up my website must have helped. Thank you so much. Have a great day.

The topic ‘Links won’t work’ is closed to new replies.