latex path not specified errors

  • Author
    Posts
  • #2503464

    malcolmgin
    Member

    On my post where I use latex markup extensively, instead I am seeing various forms and dimensions of red text against a yellow background that reads ‘latex path not specified’.

    The specific post is:
    http://www.malcolmgin.com/geekblog/2015/08/13/the-notability-of-latex-82000_10/

    I’ve reached out to my hosting provider and they don’t seem to know what’s going on.

    This support post seems to imply that the issue is a known issue with the core WordPress functionality (https://en.forums.wordpress.com/topic/latex-path-not-specified-errors?replies=3#post-2501396), but googling and searching has turned up nothing. Where is the setting that I can specify or check that the latex path is specified properly, and how do I go about troubleshooting it or helping my hosting provider troubleshoot it?

    Thanks in advance!

    #2503540

    malcolmgin
    Member

    Update, looking at the WordPress-generated HTML, it looks like latex rendering is linking to wordpress servers? The image for the first latex render is linked to the url: http://s0.wp.com/latex.php?latex=%2882%2C000%29_%7B10%7D&bg=ffffff&fg=000&s=0

    Which is definitely not under my control. Note that going to this URL in my browser gives me a standard HTTP 404 error.

    Also, upon page reloads, it looks like the rendering may actually be valid, briefly, and then updated with the error message. Which is, tbh, a little weird, but maybe that’s a browser caching issue?

    Note also that SOME renders are working. In my post, I render 2^0, 2^1 and 2^2, and they are working properly:
    http://s0.wp.com/latex.php?latex=2%5E0&bg=ffffff&fg=000&s=0
    http://s0.wp.com/latex.php?latex=2%5E1&bg=ffffff&fg=000&s=0
    http://s0.wp.com/latex.php?latex=2%5E2&bg=ffffff&fg=000&s=0

    Finally, here’s a screenshot of what I see vis a vis the actual error.

    #2503546

    teorth
    Member

    I’ve had this issue on my blog in the last two days too (though they are not visible currently because I rolled back the articles). It appears that any latex fragment that could not be rendered from a cache (i.e. a rendering of a LaTeX fragment that had not previously been rendered) is giving the latex path error.

    #2503550

    malcolmgin
    Member

    Doing more troubleshooting, I saw that some s0.wp.com URLs are rendering fine on the s0.wp.com site, but not rendering fine in my post.

    e.g.
    http://s0.wp.com/latex.php?latex=%2882%2C000%29_%7B10%7D&bg=ffffff&fg=000&s=0
    Renders as “latex path not specified” on my post, but is properly rendering as the actual link.
    http://s0.wp.com/latex.php?latex=%2831%29_%7B8%7D+%3D%3D+%2825%29_%7B10%7D&bg=ffffff&fg=000&s=0, but link, properly rendering.

    Also, shorter expressions, like the 2^0 and 2^1 and 2^2 linked above, as well as pi at: http://s0.wp.com/latex.php?latex=%5Cpi&bg=ffffff&fg=000&s=0 are rendering properly both in browser and in post.

    I wonder if someone set a timeout threshold or bandwidth threshold in WordPress core that’s replacing rendered content on s0.wp.com with “latex path not specified” somewhere? Is this an editable or overridable value, perhaps, in the config file?

    #2503552

    malcolmgin
    Member

    Also, I was unable to find the string, “latex path not specified” using the command ‘grep -r “latex path not specified” .’ in my wordpress application directory, which again argues that the issue may be somewhere within the WordPress.com latex-rendering infrastructure.

    #2503554

    malcolmgin
    Member

    More troubleshooting: Disabling Jetpack seemed to restore latex rendering properly. Drilling into Jetpack settings now.

    #2503556

    malcolmgin
    Member

    With JetPack enabled but Beautiful Math turned off, latex markup is left as a string, and “latex path not specified” does not display.

    With JetPack enabled but all settings at default, “latex path not specified” does display.

    With JetPack disabled, proper LaTeX markup displays properly. Seems like a conflict somehow between WordPress core LaTeX handling and JetPack LaTex handling.

    Still playing with likely JetPack settings.

    #2503568

    mirdonamy
    Member

    I’m having the same issue, and I’m really worried. I teach math, and I have students who use this site all day every day! If you hear anything, please please let us know! I really don’t know what to do!

    #2503572

    mirdonamy
    Member

    I don’t have JetPack enabled / connected. I use WordPress on my own domain. I use Easy WP LaTex, not Beautiful Math.

    #2503573

    malcolmgin
    Member

    I’ve sent a support request to Jetpack support, linking to this thread as well as providing other information.

    I’ll update here if I hear back.

    #2503578

    mirdonamy
    Member

    Thank you!!!

    #2503579

    malcolmgin
    Member

    Okay, well we’ll see whether anyone can respond.

    I think the JetPack thing may have been a false positive with WP Fast Cache, but I’ve tried various ways of enabling/disabling both JetPack and WP Fast Cache and can’t seem to fix it.

    Still suspecting it’s WordPress core that’s causing the issue somehow, especially now that you’ve said that you don’t use Jetpack’s Beautiful Math.

    #2503584

    chadmspooner
    Member

    The same thing has been happening to me the past couple of days. I don’t use JetPack. I’m just writing a free WordPress blog. Latex working well for months, and I write posts using Chrome under linux and W10.

    I doubt the problem here is with JetPack.

    I’m with Malcolm in suspecting WordPress broke latex after some internal software upgrade.

    WordPress: Help!

    #2503585

    mirdonamy
    Member

    I just fully deactivated and uninstalled JetPack. Still didn’t help. Do you think I should put it back in? I think the address is a WordPress issue. Isn’t JetPack a plugin?

    #2503587

    malcolmgin
    Member

    Yeah, let’s take the focus off Jetpack for now.

    #2503590

    mirdonamy
    Member

    So, any of you have connections at WordPress to reach them where they will respond to us? Our students’ math lives are at stake! :)

    #2503597

    Mee, too. It’s hurt. I am using Genesis, too, and I also lost one function in functions.php. Maybe wordpress update?

    #2503625

    mirdonamy
    Member

    I hope they will do an urgent update, fast! This loss of LaTeX is hurting so many of us!

    #2503628

    mirdonamy
    Member

    If a WP staffer wants to see this issue, it is all over my math website. I have not changed anything in the code. I’ve been using Easy WP LaTeX for years, and it has always worked up until last night! I haven’t made any changes to my site, and this same issue appears to be happening to a lot of people.

    Here is one example page from my school’s site:
    http://newvillagegirlsacademy.org/math/?page_id=2383

    #2503654

    malcolmgin
    Member

    Due to feedback from an official moderator on another thread on this site, I’ve resubmitted this question on WordPress.org here: https://wordpress.org/support/topic/latex-path-not-specified-errors?replies=1#post-7685268

    If the mods could keep this discussion around, I would appreciate it, since it has debugging and troubleshooting information from multiple contributors that might prove helpful.

The topic ‘latex path not specified errors’ is closed to new replies.