JetPack Instl issue with SSL and lighttpd

  • Hi, I’m having the “Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL.” error come up. I don’t have W3 Total Cache installed. I think it’s an issue with our server and SSL. However tried the “if ( false && $jetpack->use_ssl[$method] ) {” switch and still not working. The server is running lighttpd.

    do you have any suggestions? Thanks.
    Blog url:

  • Hi there,

    Just a few questions:

    – What do you have listed as the WordPress address and site address at Settings → General in your dashboard?

    – Are you running any other plugins?

    – If you have SSH access, could you try running the following command, and reporting back with the results?

    curl -i -L –data ‘test’ ‘’

  • yep,

    have wordpress and site address set to:

    I’ve tried deactivating all plugins and running Jetpack. Same error. using Disqus, Facebook Like, Facebook page publish, Flexible Lightbox, Google XML sitemaps, JQuery Lazy load, Thesis Openhook, Twitter tools, WordPress stats, Wordpres SEO, WP Stats Dashboard

    I’ve tried running that command, but apparently curl isn’t installed. Will have to get back to you on that one!


  • ok, here we go. This is what I’m getting back…

    HTTP/1.1 400 Bad Request
    Server: nginx
    Date: Mon, 03 Oct 2011 18:15:56 GMT
    Content-Type: application/json
    Transfer-Encoding: chunked
    Connection: close
    Vary: Cookie
    X-hacker: If you’re reading this, you should visit and apply to join the fun, mention this header.
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Mon, 03 Oct 2011 18:15:56 GMT
    Cache-Control: no-cache, must-revalidate, max-age=60
    Pragma: no-cache

    {“error”:”home_missing”,”error_description”:”The required \”home\” parameter is missing.”}

  • Can you please ask your hosting provider if they’re blocking xmlrpc.php?

  • Hi macmanx, we host it on our own server.

    When checking I do get back this…

    “XML-RPC server accepts POST requests only.”

    so appears to be functioning.

    What does “The required \”home\” parameter is missing.” mean?

  • What does “The required “home” parameter is missing.” mean?

    That error means that Jetpack was unable to read some data that it needs.

    Just to make sure it’s not a plugin incompatibility issue, are you absolutely certain you disabled all plugins and cleared any server side cache and tested the connection while the plugins were disabled?

    Could you please tell us what you have listed for WordPress Address (URL) and Site Address (URL) on your main settings page in your blog dashboard?

  • Ok,

    Yes, all plugin were disabled/cache cleared. Just tried again to double check.

    urls for both are set to

    any ideas?

  • Thanks. The result of that test are helpful, but that error response is actually the expected response for that cURL command.

    Could you please paste (or screenshot) the full error message you see when you try and Connect the Jetpack plugin to Everything in the blue box. There are (unfortunately) several error messages that look similar but mean different things.

  • Sure, here you go…

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32601

    Try connecting again. Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to Connect to again, reactivate W3 Total Cache, then clear W3 Total Cache’s cache.

  • I haven’t yet been able to figure out any reason you’re getting this error. Here’s some questions that might help us get to a solution.

    Does your server use any kind of caching? Common opcode caches: APC, Zend Optimizer, eAccelerator. Common object caches: memcached, APC.

    Is your site behind any kind of proxy/cache server/load balancer?

    Is your site running on one server or multiple servers?

    Does your server have multiple WP installs on it?

  • Hi mdawaffe,

    I’ve checked all of this and the answer to each is no.

    It’s a simple Lighttpd server set-up. Could that be the problem itself? So far, I’ve not had any other problems. Oh, except for not being able to auto-update wordpress or plugins. I get the “Could not create directory…” error.

    could this be related? any other idea?

  • Keyshots, oh no! I misread your earlier post about

    That URL should not return “XML-RPC server accepts POST requests only”.

    If it does, that’s a sign of something (in your case lighttpd) cacheing things it shouldn’t.

    The ?rsd URL should return something like what the following URL does:

    Another user ran into the same problem and it turned out to be their lighttpd rewrite rules that were causing the problem.

    They had been using the following rewrite rules configuration:

    #Jetpack is broken with these rules
    url.rewrite-once = (
     "^/(wp-.+).*/?" => "$0",
     "^/images/.*/?" => "$0",
     "^/temp/.*/?" => "$0",
     "^/(sitemap.xml)" => "$0",
     "^/(xmlrpc.php)" => "$0",
     "^/keyword/([A-Za-z_0-9\-]+)/?$" => "/index.php?keyword=$1",
     "^/.*?(\?.*)?$" => "/index.php$1"

    When they switched to:

    #Jetpack works with these rules
    url.rewrite-if-not-file = (
     "^/(wp-.+).*/?" => "$0",
     "^/images/.*/?" => "$0",
     "^/temp/.*/?" => "$0",
     "^/keyword/([A-Za-z_0-9\-]+)/?$" => "/index.php?keyword=$1",
     "^/.*?(\?.*)?$" => "/index.php$1"

    Jetpack worked.

    The user was kind enough to write up the problem and their solution at

    I’m not familiar with lighttpd’s configuration, but it looks like some of those lines are specific to their setup and not generally applicable. I think the important piece of the puzzle was switching from url.rewrite-once to url.rewrite-if-not-file and removing the xmlrpc line.

    Is your lighttp configured similarly to the “broken” configuration above (the first one)?

    Sorry for the goose chase about the other cacheing systems, we should have caught the ?rsd fact earlier.

  • Ok, this is starting to make more sense now. Thanks mdawaffe.

    I’m definitely unfamiliar with this though. Would you happen to know where the rewrite rule configuration goes?

  • If you’re with a hosting provider, you’ll need to contact them for assistance.

    If you own the server, I believe the change needs to be made in your lighttpd.conf file.

  • YES!!!!!1

    my goodness, after a few long weeks, JetPack is loaded and working.

    I just added a ‘wp-rewrite.conf’ file to etc/lighttpd instead of modifying anything in lighttpd.conf.

    Thanks again EVERYONE for helping and especially to mdawaffe and macmanx for getting me lined out in the end! Thank you!!

  • Another user had luck with the following configuration. Again, I don’t know anything about lighttpd :)

    url.rewrite-once = (
    "^//(.*)\.(.+)$" => "$0",
    "^/(wp-.+)$" => "$0",
    "^/xmlrpc.php(.*)?" => "$0",
    "^/sitemap.xml" => "$0",
    "^/(.+)/?$" => "/index.php/$1"
  • The topic ‘JetPack Instl issue with SSL and lighttpd’ is closed to new replies.