Issue with OpenID no longer working as it should

  • Author
    Posts
  • #2171891

    mrsbearfoot
    Member

    First of all, let me say I am not a technical person. I merely have a personal blog on WordPress.com and I frequently comment on Google/Blogger blogs.

    My issue is this. As of the last 6-8 weeks or so, when commenting on Blogger blogs, my OpenID is no longer sufficient. Even though the blogs I’m commenting on do not have CAPTCHA enabled, the box still appears and I must fill out the CAPTCHA letters or numbers to prove I’m ‘not a robot.’ This is on each and every Blogger blog on which I comment.

    From what I have been able to find online (and not from Google) – and I do not know if it is true – OpenID does not provide third-party authentication to Blogger (and, no, I do not understand what that means, other than I now have to fill out the CAPTCHA box at Blogger).

    I was told in an e-mail from OpenID Foundation that I need to contact my OpenID provider (which I would think is WordPress). I am hoping someone here can tell me what is now causing this hiccup and if it can be fixed. I have been commenting on these Blogger blogs for several years using my OpenID and would prefer to continue using OpenID.

    Thank you in advance for the assistance.

    The blog I need help with is thirtysevenandcounting.wordpress.com.

    #2171993

    justjennifer
    Member

    OpenID has not really worked consistently for me for the past 5 years when commenting on blogger sites, even though I have approved access to my WP identity. I’ve opted to use the name/URL combination instead.

    Regardless, I’ve tagged this for Staff input. Please be patient while waiting for their reply and don’t bump this thread with a new reply (even to say thanks) because that pushes this thread lower in their active queue.

    #2172176

    rachelmcr
    Staff

    Hi there,

    Do you know if the owners of those Blogger blogs have turned on the “word verification” setting on their blogs? That setting on Blogger adds a Captcha form when you leave a comment:

    https://support.google.com/blogger/answer/42520

    #2172181

    mrsbearfoot
    Member

    Rachelmcr, as stated in my second paragraph above, those blogs do *not* have word verification turned on.

    And now I’m confused because justjennifer above said “don’t bump this thread with a new reply (even to say thanks) because that pushes this thread lower in their active queue.” So now you and I have managed to bump this thread into a lower priority without having a solution.

    For any others who may read this, it is STILL very much an issue with the CAPTCHA box and I would appreciate constructive assistance.

    Let me re-iterate that I was told in an e-mail from OpenID Foundation that this needs to be brought to the attention of my OpenID provider (which I would think is WordPress). I have been commenting on these Blogger blogs for several years using my OpenID and would prefer to continue using OpenID.

    The name/URL option gets the same CAPTCHA box result as using OpenID, only without the benefit of the Gravatar image.

    I am seeking a solution or the proper channels to connect with the techs who can correct this issue.

    #2172185

    rachelmcr
    Staff

    Hi there,

    as stated in my second paragraph above, those blogs do *not* have word verification turned on.

    Sorry about that! I missed that part of your original post. I am checking with our team now to find out more about why the CAPTCHA box is now appearing when you’re using your OpenID.

    (I’m a WordPress.com staff member, so I’ll help you with this issue and make sure the right folks on our team are aware of what’s going on. Thanks for reporting this!)

    #2172189

    rachelmcr
    Staff

    Hi there,

    Our team confirmed that we haven’t made any changes on this end that would affect how OpenID works on Blogger. After doing some additional digging, we found that Google is introducing new CAPTCHA features:

    http://googleonlinesecurity.blogspot.co.uk/2014/12/are-you-robot-introducing-no-captcha.html

    When I tested this out with my OpenID, that’s the new CAPTCHA that I’m seeing on Blogger, even when the blog has CAPTCHAs turned off. That’s a Google/Blogger feature, so it isn’t something WordPress.com can control from this end.

    #2172190

    mrsbearfoot
    Member

    Thank you so much for taking the time to investigate this. Up to this point, I have not been able to find any explanation on Google/Blogger, so the link you provided is helpful. My issue is still not resolved, since just yesterday (12/23/14) I was still having to type the distorted text even though I checked the “I’m not a robot” box. It’s not consistent. Last week I was able to comment, check the box, provide my Open ID and that was good enough.

    It’s frustrating. But again, I do appreciate your assistance and persistence, and understand it’s not a WP issue.

The topic ‘Issue with OpenID no longer working as it should’ is closed to new replies.