Import from typepad .txt file not working

  • Author
  • #1026630

    Hello, I exported my blogs from typepad and saved as .txt then I followed the instructions from the site above. I was able to upload the file, and it asked me to select an author. After that, it took a few seconds, then I was left with a blank white screen (with the wordpress navigation bar and header still there). No error message was received, but no posts were uploaded either. I tried multiple times to no avail. I would greatly appreciate any suggestions.

    The blog I need help with is



    Hi there,
    I have flagged this thread for Staff assistance.


    Additional info – if relevant – for every time I tried to import, I received notification to my email that the import was successful, but the posts were not actually imported. I will try a couple more times, maybe using another browser? I typically use Firefox.



    I have exactly the same issue. I exported my blog out of Typepad, and used the importer. It all seemed to go fine, I shortly afterwards received an email to advise the import was successful. However, none of the imported posts show up.



    OK, I figured this out after hunting around online. Hopefully this helps others.

    I’m using a Mac. When I downloaded the export file from TypePad, it saved to my Mac with the extension .txt.

    That file uploaded to WP fine, I even got the email advising my import was successful. But no posts appeared.

    I changed the extension of the import file to .xml, and this time the import worked fine.

    Looks like something to do with Mac/Typepad using a .txt extension when downloading the file from Typepad.

    Would be a help if this highly useful snippet was included in the help pages for import.


    That worked like a charm. I still went to the blank screen after import, but when I viewed Posts, alas they were all there! Thanks a lot daviddeedle!

The topic ‘Import from typepad .txt file not working’ is closed to new replies.