HTML IN Post?

  • Author
    Posts
  • #363091

    sseverson389
    Member
    Original poster

    http://www.hundredgoals.com

    I wrote HTML for a text widget to allow my readers to subscribe to my blog through email, facebook, feedburner and twitter and would like to be able to use this code at the end of my daily posts, but when I copy and paste the html from the widget into the post, it doesn’t work. It shows up as code, not how it looks in my widget.

    Can anyone offer some suggestions of how to fix this problem?

    The blog I need help with is: hundredgoals.com

    #363271

    If it works in the widget, it should work in the post too (I tried your code and it does). You’re either trying to paste it in the visual instead of the html post editor, or you’re making some mistake in the copypasting. If you wish, you can paste the code here between backticks so we can see what you’re trying to put in the post.

    #363303

    sseverson389
    Member
    Original poster

    Thank you! I figured it out, however I have another couple of questions about the widget. I’d like to make the icons in the widget identical to those which are found in the article posts, with a border and shadow. I’m not sure how to get this to work, I tried looking at the source of the page and copying & pasting the HTML from that, but it made my page go wacky.

    Also, I’d like to indent the icons so they are in line with the text links in the other widgets directly below. Thanks for your help so far!

    #363304

    That style is built into the theme. Most themes present images plainly, some framed, yours with drop shadows. You can mimick that by adding this to the image code (after “img”, with a space before and a space after):
    style="border-top:solid 1px #ddd;border-left:solid 1px #ddd;border-right:solid 4px #ccc;border-bottom:solid 4px #ccc;padding: 4px;background: #fff;magin-right:2px;"

    To get the contents of a widget in line with the rest of the widgets content, you need the code for unordered lists; in your case:

    <ul><li>
    FULL_CODE_OF_THE_FOUR_IMAGES_HERE
    </li></ul>

    #363305

    Sorry, a typo in the first code: “margin”, not “magin”.

    #363312

    sseverson389
    Member
    Original poster

    Thank you sooo much! You’ve been more than helpful! It looks great! I appreciate your help very much! I wish I could shake your hand! :)

The topic ‘HTML IN Post?’ is closed to new replies.