'hrefi.li' Being Added to Certain Links on a Coming Soon Site's Page

  • Author
    Posts
  • #3509527

    writer0001
    Member

    Hi,

    I’m creating a page about how to access my Members-Only Area site (which is a Private site). The URL is https://joannaandbellasbooks.home.blog/members-only/. (The site is set to Coming Soon.)
    I have some links on this page, going to the following sites and pages:

    #1: The blog page for the site I am editing (https://joannaandbellasbooks.home.blog/blog/)

    #2: The blog page for Somellenna (https://somellenna.wordpress.com/blog-2/)

    #3: The blog page for The Writing Website (https://writingwebsite.poetry.blog/blog/)

    #4: The Private site itself (https://joannaandbellasbooksmembers.home.blog/)

    #5: The page on this Private site called Exiting the Members Area (https://joannaandbellasbooksmembers.home.blog/exiting-members-area/)

    #6: The page to create an account with WordPress.com (https://wordpress.com/start/)

    #7: The page to log in to WordPress.com (https://wordpress.com/log-in/)

    #8: The support forums for WordPress.com (https://wordpress.com/forums/)

    #9: The support forums for WordPress.org (https://wordpress.org/support/forums/)

    #10: A Somellenna post explaining about all my blogs (https://somellenna.wordpress.com/2019/12/08/finally/)

    The links to the blog page of https://joannaandbellasbooks.home.blog/ (#1) and to WordPress.com pages (#6, #7 and #8) went to the correct page.
    However, for all other links (on The Writing Website, Somellenna and WordPress.org), the link automatically added https://href.li/?https:// to the start of the URL when I clicked the link. The page it takes me to displays this message:

    This site can’t be reached
    href.li took too long to respond.
    Try:
    Checking the connection
    Checking the proxy and the firewall
    Running Windows Network Diagnostics
    ERR_CONNECTION_TIMED_OUT

    This has been happening pretty much since I created the page (though if I remember correctly it may have worked for a day or two?). At first I thought it could be something to do with the site being set to Coming Soon, but I then published the site; nothing changed. I suppose I understand why the links to pages within the same blog would work, but not why anything else except WordPress.com would work. It’s also important to note that I have links on The Writing Website/Somellenna to my other blogs, and these seem to work.

    I tried this on Chrome, Edge and Explorer. None of them worked, and the same links still displayed the same error messages.
    Chrome Version: 83.0.4103.97 (Official Build) (64-bit)
    Microsoft Edge Version: 44.18362.449.0
    Microsoft EdgeHTML Version: 18.18363
    Explorer Version: 11.836.18362.0
    Chrome Extensions: (I tried with these disabled)
    (I couldn’t find where my Edge and Explorer extensions were listed)
    I have cleared browsing history, cache and cookies.

    I have copied these links and checked they don’t add this href.li when just searched normally, and they don’t. I also went to the links directly from the Block Editor, and they worked.

    Please could someone explain why this is happening, and how to fix it?

    Thank you.

    The blog I need help with is writingwebsite.poetry.blog.

    #3509659

    justjennifer
    Moderator

    Hi there, That ‘href.li’ is there because your site is still Private. What is does is hide the referrer link on other sites. Once your site is public, that should go away.

    If you want to bypass it before your site is public, head to your site’s WP Admin>Settings>Reading> scroll down to

    Link Visibility

    I would like my links to be public, without being passed through a referrer hider.

    tick the box and then save your settings.

    Hope that helps but post back here if you have other questions.

    #3509747

    writer0001
    Member

    Thanks so much @justjennifer for the fast response! That did work, thank you very much!

The topic ‘'hrefi.li' Being Added to Certain Links on a Coming Soon Site's Page’ is closed to new replies.