Front page now showing all blog posts, instead of most recent

  • Author
  • #820631

    For months, when people go to my blog, they saw the ten most recent posts (as set in Settings – Reading), then at the foot of the screen were my copyright notices, number of hits and followers, etc, as set in my widgets.

    Two days ago, without my changing anything, something changed, and now when you go to the blog and scroll down, the posts just keep loading and loading and loading – and you have to wait forever to get to the foot and the widgets.

    My Settings – Readings is unchanged: it still says to show the last ten posts.

    What is going on, please? And how can I get back to what I had – the last ten posts, and then the foot widgets? Thank you.
    Blog url:




    We’ve launched a new feature called infinite scroll that makes it easier for your readers to read your work.

    Instead of having to scroll and click through to different pages, they can scroll and pull new content automatically. As a result, we believe users will spend more time engaging with your blog.

    Feel free to drop us a line if you have any questions, or if we can be of any further assistance. :-)


    Is it possible to turn off this infinite scroll, as I really don’t like it – it is disorientating, as you can’t tell where you are in the string of posts. I can see that some people might like it, but is it an option I can turn off?
    Thank you.



    Not at this time, but we are looking into an option.


    Please, please do – I have had so many complaints from users who liked the old, cleaner appearance of the blog – they find the constant refreshing and reloading very peculiar, and they also want to get to the bottom to see my site stats. (The sidebar widgets are already full.) I chose this template because I liked its clean lines, and now they are being changed.
    Thank you for your help.



    It’s possible that we may have something this week.


    When you do, please will you post on this forum, so that I get an email and can select the opt-out?
    Many thanks indeed.



    We definitely will.



    You’re all set now. If you have footer widgets set, you’ll find a nice new option in Settings -> Reading to check.


    Thank you, thank you, thank you to infinity! I am delighted!



    Glad to hear that :)

The topic ‘Front page now showing all blog posts, instead of most recent’ is closed to new replies.