Custom Background and Header links in admin panel redirect to Customize page

  • Author
    Posts
  • #2416449

    justjennifer
    Moderator

    @musicdoc1 Actually I think that once you’ve “exited the preview” a cookie is set and it stays that way.

    I haven’t had a chance to test this after clearing my browser cache and cookies. It’s late-ish where I am, but I’m after a long day so any further testing will have to wait until tomorrow.

    #2416450

    musicdoc1
    Member

    @musicdoc1 Actually I think that once you’ve “exited the preview” a cookie is set and it stays that way.

    Yes, that would explain it. I’ll try to test that later.

    #2416456

    justjennifer
    Moderator

    Just logged in this morning to my test site and it looks like there is a server side setting (I clear my cache and cookies daily). No

    This feature is a part of the Premium Plan. Purchase to make it live or exit the preview.

    notice under the Colors & Backgrounds as previously and all the Custom Design tools are tucked away under one drop down menu.

    If you open that menu and click the “Try Now” button, it reloads the Customizer and it appears as it did yesterday before the change.

    So maybe no longer misleading, but still confusing.

    However, looking at the Customizer in one of my other sites, it appears like it did in my test site did yesterday. The Colors & Backgrounds still show that this feature is part of the Premium Plan.

    #2416457

    I do have a same issue here, but only for my main wordpress. I attempted to change background image at a clone one yesterday. Surprisingly, it worked.

    #2416467

    rachelmcr
    Staff

    Thanks for all of your testing and feedback on this. I just want to confirm a couple things you mentioned:

    @justjennifer:

    Even after I clicked the exit preview and successfully changed the background color, my natural tendency was to click the “Save and Publish” button, but it didn’t change to “Saved” when I clicked it and clicking the X to exit brought up a warning in the browser that I was about to leave the page without saving my changes.

    Thanks for pointing this out. I just walked through a few different scenarios and saw similar issues to what you describe. I’m passing along that feedback to our team.

    Just logged in this morning to my test site and it looks like there is a server side setting (I clear my cache and cookies daily).

    Once you open the custom design preview, that preview is active on the site and will stay active until you upgrade or exit the preview. Once you exit the preview, you’ll be out the preview mode until you head to the Custom Design section and try it out again.

    If you’re seeing that preview on sites where you didn’t choose the “Try Now” button in the customizer or otherwise opt in to try those features, please let me know.

    @musicdoc1:

    having the link to the old custom background page go to the Customize preview screen by default, and then requiring that one “exit the preview” to use the free option, is rather counterintuitive. That’s what happened when I tried to change the custom background yesterday.

    I haven’t been able to reproduce this behavior on my end, and as far as I know it isn’t intended to happen. You mentioned that this isn’t happening on your site anymore, is that right? If that happens again, please let me know which site it happened on so I can take a closer look.

    #2416468

    musicdoc1
    Member

    @ rachelmcr,

    I haven’t been able to reproduce this behavior on my end, and as far as I know it isn’t intended to happen.

    Perhaps you’ve misunderstood what I said here:

    having the link to the old custom background page go to the Customize preview screen by default, and then requiring that one “exit the preview” to use the free option, is rather counterintuitive. That’s what happened when I tried to change the custom background yesterday.

    This is the principle issue of the topic. Another way of saying what I said in the topic title. On the day that I first reported the issue, and on my first couple of attempts on the following day, the Background and Header links in the admin panel at Appearance > Background (or Header) opened to a Customize page where the Colors & Background feature was identified as a Premium Plan feature. In other words it opened with the preview activated by default on that feature.

    It may not have been significant that I reached the Customize page with the preview activated on Colors & Background from an admin panel Background or Header link. In other words, using the Customize link at Appearance might have had the same result. I don’t think I tried that at the time I noticed the issue. I probably should have reported two separate issue, instead of combining them as one as I did. The issues I discovered on 26 June were:

    1. The classic custom header and custom background pages can no longer be found. Links to them in the dashboard admin panel go the Customize page.

    2. The Customize page displayed the trial or preview version of the Colors & Background feature by default, requiring that the user exit the preview to get to the free version.

    The first issue remains, but I can no longer reproduce the second issue. Minutes ago, I visited the Customize page on two new sites (one created yesterday, and one today) and found the Colors & Background feature to be the free version by default in each case. Also, this was the result regardless of which link I used to get to the Customize page.

    However, in her most recent post here, justjennifer reported that she was still encountering the issue:

    However, looking at the Customizer in one of my other sites, it appears like it did in my test site did yesterday. The Colors & Backgrounds still show that this feature is part of the Premium Plan.

    #2416469

    justjennifer
    Moderator

    @musicdoc1 – it makes sense when you remember that the upgrade is per site.

    Update:
    Looking now in my test site’s Customizer, it has reverted to what it was yesterday.

    #2416470

    musicdoc1
    Member

    @ justjennifer,

    I don’t follow you. I’m not seeing the preview version by default anymore on any site in the account.

    #2416471

    justjennifer
    Moderator

    Click on my last screenshot. https://cldup.com/CyCX3wU7NF.png That’s currently the way my test site’s Customizer looks, which is the way it started out yesterday.

    When I posted here https://en.forums.wordpress.com/topic/custom-background-and-header-links-in-admin-panel-redirect-to-customize-page?replies=28#post-2416566 this is what the Customizer looked like at that time. https://cldup.com/mHR4Prlawu.png

    #2416473

    musicdoc1
    Member

    Your results are clear, and I’m not disputing them. I may have gotten different results on my test sites because I didn’t clear my browser cache and cookies. I remained logged into the account throughout the testing.

    #2416474

    justjennifer
    Moderator

    Good to note.

    But somewhere in the middle of the day, my test site’s Customizer reverted to the previous version and while I’m sure I logged out, I didn’t dump cache and cookies.

    Well, this is taking time away from other things that need doing, so that is the extent of my testing until Staff have this sorted. Thanks for bringing up the topic. :)

    #2416476

    rachelmcr
    Staff

    @musicdoc1:

    1. The classic custom header and custom background pages can no longer be found. Links to them in the dashboard admin panel go the Customize page.

    That’s the intended behavior for those links. The core WordPress software no longer links to those Header and Background pages, using the customizer to make those changes instead. WordPress.com is now reflecting that core WordPress behavior.

    2. The Customize page displayed the trial or preview version of the Colors & Background feature by default, requiring that the user exit the preview to get to the free version.

    That shouldn’t happen, unless you previewed the custom design features (and didn’t exit them) the last time you used the customizer. Since you can no longer reproduce that issue, it sounds like everything is working for you as expected.

    @justjennifer:

    So the customizer went back to showing the custom design preview without you clicking that “Try Now” button again? Hrm, that shouldn’t happen. Would you mind if I tried toggling that custom design preview on and off there, to test it out? I haven’t been able to reproduce that issue elsewhere at this point.

    #2416477

    justjennifer
    Moderator

    Feel free. If you'd find it helpful I can send you privately a link to the stream of screenshots I made earlier.

    #2416478

    musicdoc1
    Member

    @ rachelmcr,

    That’s the intended behavior for those links. The core WordPress software no longer links to those Header and Background pages, using the customizer to make those changes instead.

    Understood. My complaint regarding this change is four-fold:
    1. No notice of the impending change was received.
    2. I greatly prefer the old custom header and custom background pages to the corresponding cramped corners of the customize page, in much the same way that I prefer a luxurious living room to a phone booth.
    3. I had no use for the Customize page until this change. Never used it unless I was investigating an issue reported in a forum topic.
    4. The Customize page takes a ridiculously long time (48 seconds in my latest test) to load on my PC. This WP mod will therefore have the effect of forcing me to change my front page from the posts page to a static front page, or else drastically limit the number of and length of the excerpts displayed on each page.

    #2416481

    musicdoc1
    Member

    @ justjennifer, @ rachelmcr

    However, looking at the Customizer in one of my other sites, it appears like it did in my test site did yesterday. The Colors & Backgrounds still show that this feature is part of the Premium Plan.

    I was able to reproduce this effect this afternoon on some sites, without any clearing of the cache or cookies, but not on others. The pattern I discerned in my limited trials was as follows:

    1. Sites created more than a roughly a year ago do not display the trial (preview) version of the Customize page. *

    2. Sites created within the last year or so do display the trial version of the Customize page, with the exception of very recently created sites.

    3. Sites created in the last two days, do not display the trial version of the Customize page.

    It’s possible that whether or not the site displays the trial version of the Customize page has more to do with alltime usage, recent usage, content, or some other as yet identified factor, than it has to do with the age of the site.

    * Those sites which display the Colors & Background feature as a premium plan feature by default also display the other premium plan features: Fonts and CSS, whereas those which do not display the Colors & Background feature as a premium plan feature have a Custom Design tab that opens to the “Try Now” page. If you click the “Try Now” button you go to the trial version.

    #2416482

    musicdoc1
    Member

    For each item of the list in the previous post I meant “display the trial version of the Customize page, by default.”

    #2416483

    justjennifer
    Moderator

    @rachelmcr I think @musicdoc1 might be on to something there about which menu appears in the Customizer having to do with the age of the site.

    #2416485

    rachelmcr
    Staff

    @justjennifer:

    Thanks, I exited the Custom Design preview and poked around, but nothing I did re-enabled that preview mode in the customizer. No matter what link I use, the customizer opens in the regular, free customizer mode. Can you let me know if that changes again on that blog? (If it changes, it’d help to know exactly what link you used to open the customizer and if you remember any other changes you made to the blog that might be relevant.)

    @musicdoc1:

    I haven’t been able to reproduce that behavior on any test blogs of any age. Can you send me links to the blogs where that Custom Design preview mode was active before you hit the “Try Now” button so I can take a look? (Keep in mind that the preview mode isn’t linked to your browser’s cache/cookies, so clearing those won’t affect whether or not the preview mode is active. If you ever tried the Custom Design preview mode on a particular blog without exiting it afterwards, it will remain active in the customizer until you decide to exit that preview mode.)

    #2416487

    justjennifer
    Moderator

    @rachelmcr As of right now, the Customizer appears as per this screenshot https://cldup.com/mHR4Prlawu.png

    #2416489

    rachelmcr
    Staff

    Thanks! That’s the expected view when you’re viewing the Customizer normally (not trying out the Custom Design features).

The topic ‘Custom Background and Header links in admin panel redirect to Customize page’ is closed to new replies.