Connecting Klout using JetPack

  • Author
  • #1052674


    Cannot connect (self-hosted connected to via Jetpack). Didn’t even see an option to type a URL… The screens cycle through blog admin login and Klouts’ message “You must enter a blog or a Jetpack powered site.”



    same problem here…


    For those still experiencing this problem, may I suggest you partake in the Jetpack user survey if you haven’t already. It’s available at the bottom of the Jetpack screen after logging in to your WP site. Most relevant will be the two last questions:
    Q.6 What’s the most frustrating thing about Jetpack?

    Q.7 What would you like to see added to Jetpack?



    I’m also having this issue. My site is



    I have the same issue with my sites: or and all my other blogs on wordpress.



    Time to get this fixed. Come on, Klout and Jetpack people! A few conference calls, a virtual tour of the offending code by developers on both ends, and it should be done in two days max.



    Unbelievable that the bug is still not fixed since months!



    This is a crime against humanity, literally worse than 10 holocausts.



    This is a crime against humanity, literally worse than 10 holocausts.

    I cannot believe that anyone would compare waiting for Staff on a computer issue to the deliberate and systematic annihilation of 6 million human beings.


    Yeah I’m going to go ahead and think that @caustik was being satirical in light of the comments preceding.

    Perhaps some peeps want to turn their computers off and go for a walk around the block.

    Except you guys at WordPress working this fix – you guys stay where you are and keep working this problem.



    Count me among those affected by this issue. I’m able to connect my self-hosted blog ( to my account and it appears that everything is working up to that point. However, when I try to add this to my Klout profile, I’m redirected to my blog with the message that Klout needs access to my site. When I sign in to my site, I’m then directed to my dashboard, but Klout is still not able to connect. For what it’s worth, I do find some Jetpack-related bits in the query string:


    So Jetpack is *trying* to do something on my site, but for whatever reason the operation does not complete. Help!


    Same here, the latest update of Jetpack plugin makes the connection work to an extent that you can login into your self-hosted installation, but then the system fails (on site, saying it can’t connect.



    Great news. I just updated to Jetpack 2.2 on self-hosted WP 3.5.1, turned off all plugins except Jetpack, and was able to connect Klout.


    @nelsdrums, lucky you! After your post I just tried again. De-activated all plugins, stopped, changed to standard profile, activated Jetpack again and build up connection. No chance to activate …



    After the last Jetpack update it works for me too (self-hosted WP 3.5.1).


    are you guys using same username on and on your self hosted WP?



    no, I use two different usernames



    Just right now I have been able to connect my Klout account to my self-hosted WordPress blog. The first login is to the account, so you need to use those credentials, then thereafter you need to login to your own self-hosted blog, with those credentials appropriate for that site. Bingo!

    Using WordPress 3.5.1 and JetPack 2.2 (which is also connected to
    I had no need to disable any other plugin.


    I still can’t connect either. I get further with the latest release but seem to be stuck in a loop once I provide the pw for my self hosted blog.



    Me, too! I am ending up on my dashboard of my self hosted blog!

The topic ‘Connecting Klout using JetPack’ is closed to new replies.