comments not visible

  • Author
  • #726395

    When someone posts a comment the blog post shows that there’s a comment rather than showing the comment itself. I’ve checked screen options, settings, reading, comments, support forums etc. but other than finding others have similar problems I haven’t found an answer.

    I’m at:

    How do I get my comment to show on the blog?


    The blog I need help with is



    Are you asking whether or not you can have your blog automatically display every comment without you approving any of them? If so, then have you considered how much spam will be directly posted to your blog?

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    We can also overide the default settings and enable or disable future comments on any post or page.


    My setting is currently that I want to moderate the comments before they become visible. I like that. What I want to change is – once I approve – I’d like the comment to be reable by everyone else rather than a line that says “1 comment.”



    Unless you use the P2 theme which is a Twitter-like theme. The front pages of our blogs showcase content and comments are collapsed on that page, and the way the comments function is coded into the core of WordPress. By clicking the post title or the comments link the posts on the front page open on their own page where all comments display.

    In a new blog one does not have many posts or comments. In an established blog if the comments did not collapse on the front page it would become a mile long in no time flat and page loading time is a page ranking factor. We have only seconds before visitors refuse to wait and click out.


    Okay. I understand. Thanks for letting me know.



    You’re welcome and best wishes with your blog. :)

The topic ‘comments not visible’ is closed to new replies.