Category showing but Posts not

  • Author
    Posts
  • #3044385

    maristravels
    Member

    I have typed the category in and it’s showing (it is Belgium) and I have appended two posts below it on the Menu. These, however, are not showing when I, or a visitor to my site, click on Belgium, although when my mouse hovers over Belgium the Post title comes up. When I click on it however, it says This site cannot be found, or similar.

    What am I doing wrong. My other categories all work and I can’t see that I’ve done anything different.

    The blog I need help with is travels-with-my-camera.blog.

    #3044560

    musicdoc1
    Member

    Hi,

    I have typed the category in and it’s showing (it is Belgium) and I have appended two posts below it on the Menu.

    I find one sub-menu item under the Belgium category in your menu: “A Walk on the Ramparts of Ypres.” However, that post has no category assigned to it (other than “Uncategorized”). Also, the Belgium category page doesn’t exist. The Belgium menu item links to the URL https://travels-with-my-camera.blog/category/belgium/, which produces a Not Found error, because there no published posts with that category assigned.

    #3044622

    maristravels
    Member

    Thank you for that. I don’t understand what’s happening, I thought I’d done everything in the same way as I’d always done. However, I’ve redone the category and the Post is now showing under Belgium. However, a second post is not, and this has the category Belgium listed at the bottom of the post. When I click on Belgium the Walk on the Ramparts post shows but the second post Journey’s End doesn’t show but it runs after the first post, so obviously it is categorised correctly. I would like just the titles to show when people click on the category. What do you think I am doing wrong?

    #3044644

    musicdoc1
    Member

    You have to add each menu item manually. A post isn’t automatically added to the menu because you’ve assigned a category to it. See the “Add menu items” and “Organize your menu and add sub-menus / drop-down menus” sections of the Custom Menus support page for instructions regarding adding a menu item and arranging a menu items in a drop-down menu under another menu item, respectively. This will be familiar to you, since you’ve obviously added posts to the menu before.

The topic ‘Category showing but Posts not’ is closed to new replies.