Can't delete images from library

  • Author
    Posts
  • #3028365

    apo11o
    Member

    Any reason for images refusing to be deleted from my library?

    I have allowed days to pass as I know WP caches content, but even after weeks the images are still present.

    I have clicked on ‘Deleter Permanently in all the possible image library option screens, all come up with an ‘Are you sure’ type of warning which I click ‘Yes’ to, but the image does not go away.

    I have even gone back and edited the image details to make sure it is not ‘Attached’ to any page or post, but it still does not go away after being deleted.

    I’ve tried deleting singly, and in batches, but still they persist.

    This has been the case for years, for me, until ONE image DID delete recently, but that was the only one, and repeated attempts with the others I want rid of continued to fail as usual.

    Are we not allowed to delete images if using WP’s free hosting?

    The blog I need help with is secretscotland.wordpress.com.

    #3028498

    fstat
    Staff

    Hi there,

    Have you followed this guide on how to delete files from your media library:

    https://en.support.wordpress.com/media/deleting-files/

    If you’re still having trouble deleting the images, let me know your site’s address so I can have a closer look.

    #3028548

    apo11o
    Member

    Hi,

    Oddly, I listed most of the methods I tried, hoping not to get pointed as the guide to deleting files.

    So, fun aside…

    This is where I can be found:

    https://secretscotland.wordpress.com/

    Assuming you can look at the image library, my norm is an image file generally 640 x 480 or so, and around 64 kb – good enough on screen, but grotty enough to make it not worth stealing, or being watermarked.

    There are a few LARGE images and files stuck in the library from times when finger trouble means I uploaded and original instead of a processed item.

    While it’s not a problem, the fact that I have (almost) never been able to make these large files go away is beginning to become an irritation, hence the assistance call, to find out if I am dumb, there’s an issue, or even that the feature is not on offer for hosted blogs.

    So, any hints gratefully received.

    (Oh, and that was quick!)

    #3028638

    fstat
    Staff

    I was able to delete images from your media library (I have re-uploaded them) by using both interfaces. The new one:

    https://wordpress.com/media/secretscotland.wordpress.com

    and the classic one:

    https://secretscotland.wordpress.com/wp-admin/upload.php

    Clearing your browser’s cache or using another browser might help us better troubleshoot the issue.

    #3028650

    apo11o
    Member

    I forgot about the ‘new’ interface (I really don’t like it at all) and had only been trying deletion in the classic view, so will try this option later.

    My browser cache is cleared automatically every few days.

    Not use Firefox – that will be hard ;-)

    Will update with result when I get a moment.

    Thanks.

    #3028651

    fstat
    Staff

    You’re welcome! I’ll wait for your reply :)

    #3028671

    apo11o
    Member

    While I will still stick with elegance of the original classic interface until it is killed, it looks as if I MUST remember that ‘New’ interface is there when I have any odd problems.

    Deletions seem to be fine in ‘New’, but I retried in classic just for curiosity, and that still seems to ignore any of my deletion commands.

    It’s like the bell notification icon at the top right corner. In classic, it opens the notification window… then does nothing. But when I try it in ‘New’, it does correctly fill with notifications.

    That should have been a clue for me to try your suggested fix.

    Once again, many thanks for the assist (now where did I leave all those unwanted uploads for almost 10 years!?)

    #3028685

    fstat
    Staff

    I’m glad that you found a solution! I’ll also have a look at the notifications issue you’re having.

    #3028686

    apo11o
    Member

    I wish you luck with this one.

    I always use Firefox (now using 58 Nightly) and the notification has never shown anything with classic. After opening the notification area, all that appears is the loading icon, which just plays forever.

    In ‘New’ interface, the notification opens, and is then populated within a few seconds.

    I really never thought of it as an issue, and had just assumed it was something written for ‘New’ interface, with poor old classic left behind.

    #3028687

    apo11o
    Member

    Maybe I should be a little more accurate…

    If I click on the notification ‘bell’ icon when just viewing my blog, or when in the old classic editor, the side window it opens never populates.

    ONLY if I am in the ‘New’ editor will that window populate with notifications about posts, comments etc.

    Afraid those are the only three screens I really use, so they are the only ones where I’ve clicked that bell icon.

    As I say, it’s no big deal to me, so I’m just mentioning this as you said you’d look, not expecting any answer or solution, or going to be chasing up on it.

The topic ‘Can't delete images from library’ is closed to new replies.