Cannot get Jetpack to connect "Authorization header was malformed"

  • Author
    Posts
  • #1120790

    rjburgess99
    Member
    Original poster

    Hi. I am currently on wp.com but moving to wp.org via GoDaddy. Yesterday I set up my GoDaddy account and installed WP via their 1-Click Install. My new site sits at http://headforpoints.com.previewdns.com

    When I try to connect Jetpack, I get the error: “auth_failed” and “The Jetpack server encountered the following client error: Authorization header was malformed.”. I thought it may fix itself given 24 hours from setup but it hasn’t. How can I get this to work?

    I have tried reinstalling Jetpack with no joy. There are no other plug-ins etc operating as this is a fresh WP install. Thanks.

    #1120936

    kardotim

    You might get this error because you’re using a “preview” version of your site now. I saw this message on your site.

    This is a preview of your new Web site. Once you’ve completed setting up this site’s content, you need to modify the DNS settings of your domain for it to be live to the public.
    Click here to learn more about setting your domain’s nameservers.

    If you still encounter trouble with your ‘live’ site, try to disable all other plugins and reactivate Jetpack. This way we can see if other plugins interfere with Jetpack.

    Also make sure you are running the latest WordPress and Jetpack version:
    http://www.wordpress.org
    http://www.jetpack.me

    Looking forward to your reply.

    #1120938

    rjburgess99
    Member
    Original poster

    Here’s the problem!

    It’s surely a chicken and egg situation?

    I need Jetpack on the previewdns site in order to build my new, more commerical blog ‘away from prying eyes’ until its ready. Until then, the DNS for the domain name will point to the ad-free wp.com version.

    However, you seem to be saying that I cannot get Jetpack UNTIL the blog is ‘live’ (ie the DNS is pointing to the new site and the previewdns.com drops away). This doesn’t seem to make sense.

    I’ve done a fully reinstall of WP as well (ie totally removing all the files via godaddy and reinstalling) and it still doesn’t work. The only active plug-in is Jetpack, in the latest version, with WP3.5.

    If you couldn’t install Jetpack if your site was running under previewdns, I can’t understand why this has never come up before as an issue since surely many, many sites run under previewdns before launch.

    #1120939

    rjburgess99
    Member
    Original poster

    The only alternative would seem to be to build a new blog using a different domain name. Once launched, I could then change the domain name.

    However, this causes major issues with links in posts and would also involve a day or so’s downtime, and so is obviously not ideal.

    #1120941

    kardotim

    I see. Could you please confirm that you’ve disabled all other plugins and reactivated Jetpack?

    #1120942

    rjburgess99
    Member
    Original poster

    Yes, the only plug-ins there are:

    Akismet 2.5.6 – not activated
    Follow Button for Jetpack – not activated
    Hello Dolly – not activated
    Jetpack by WordPress.com 2.1.1 = activated
    WordPress Importer – not activated

    If you email me at robert [at] robertburgess.com I can send you the log-in details so you can take a look yourself.

    #1120943

    richardmtl
    Member

    Hi rjburgess99,

    You are likely going to run into many other issues using PreviewDNS and WordPress, because many plugins will incorporate URLs that are not easily replaceable in the database but that you will need to change once the site is on its actual domain. I suggest you do your site development locally, by installing WordPress on your computer. You can find some information on how to do so on the WordPress.org Codex. There are also many tutorials available, if you search for “wordpress localhost windows”. You will also want to modify your hosts file to point your domain name to your local installation (note that you’ll have to undo your changes if you want to get to your actual live site).

    You do need to know that Jetpack won’t work on localhost however, so that doesn’t solve your original issue. I’m afraid that you also will not be able to get Jetpack running on PreviewDNS, likely because of how GoDaddy configured their servers. For example, in the Jetpack Troubleshooting tips, step #3 says to check your XML-RPC file (which is required by jetpack to run properly). If I check it by going to it on your PreviewDNS site, it doesn’t work at all:

    http://headforpoints.com.previewdns.com/xlmrpc.php

    I’m sorry I can’t help you with this any further. Please let me know if I can help you with anything else.

The topic ‘Cannot get Jetpack to connect "Authorization header was malformed"’ is closed to new replies.