Blog page not showing posts

  • Author
    Posts
  • #2846685

    tinawoolley
    Member

    I created a static front page called Home. I also created a separate page and set it to be the posts page. However, when I create new blog posts, they do not show up on the that page. Did I miss a step?

    The blog I need help with is egsd.wordpress.com.

    #2846761

    timethief
    Member

    This is a one or the other situation. You have two choices on any blog
    (1) All posts on the front page ie. the Home page. By default that is the URL of the site.

    (2) A static front page http://en.support.wordpress.com/pages/front-page/ and all posts on a different page.

    By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors, who come to read your latest post, and who are not likely to be happy with being compelled to click through the same static page with the same blah, blah, blah on it every time they visit the blog looking for the latest post.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. Create your pages first
    Front page:
    Posts page:
    http://en.support.wordpress.com/pages/

    After you do that you go to > Dashboard > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    A static page (select below)
    Front page:
    Posts page:

    Go to http://egsd.wordpress.com/wp-admin/options-reading.php and make the required change.

    Front page displays
    Save changes
    __ Your latest posts

    #2846762

    Hi. Which page did you set to be the posts page?

    #2846763

    timethief
    Member

    Every theme has a detailed theme description page and this one is at https://wordpress.com/themes/affinity/ That’s where set up instructions for it are found. The live demo site is at https://affinitydemo.wordpress.com/

    #2846810

    tinawoolley
    Member

    I have a page called Home that is my designated static front page. I created a page called Think for the blog posts and under Customization and Static Front Page, I designated that as the Posts pages. When I go to Pages, under the title of that page, it says “Think <i>Your latest posts</i>”.

    I did read the directions for the Affinity theme and I believe I followed them correctly. I then created and published 3 blog posts. The posts do not appear on the Think page.

    #2846812

    tinawoolley
    Member

    OK – figured it out. I created a new page called Posts and set it as my Posts page. They displayed just fine. When I tried to add that as a panel in the Affinity theme, it stopped displaying posts.

    #2846870

    supernovia
    Staff

    Hi @tinawoolley, I still see the latest posts here:
    https://egsd.wordpress.com/posts/

    I don’t see them displayed on the front page of Affinity though. I’m not sure whether Affinity would normally do that. If that’s what you’re after though, let us know and we’ll see if we can help you find a way to make it happen.

The topic ‘Blog page not showing posts’ is closed to new replies.